Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81080 - anaconda offers to "upgrade" my Mandrake Linux 9.0 partition
Summary: anaconda offers to "upgrade" my Mandrake Linux 9.0 partition
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-04 00:39 UTC by Richard Lloyd
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-27 22:47:46 UTC


Attachments (Terms of Use)

Description Richard Lloyd 2003-01-04 00:39:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
When anaconda searches for existing Red Hat Linux partitions and finds
some, it displays a list of them next to an "Upgrade" radio button (you
can choose to do a fresh install instead of upgrade instead of course).
However, surely it should only list *Red Hat Linux* partitions and
not other non-Red Hat Linux partitions ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a non-Red Hat Linux distro on a partition (I had
   Mandrake Linux 9.0 on one)
2. Boot the phoebe beta CD-ROM disk 1 and go into anaconda
3. Note what anaconda lists as "upgradable" Linux partitions
    

Actual Results:  I had 3 Linux partitions - two Red Hat Linux 8.0 partitions and
one Mandrake Linux 9.0 partition. anaconda listed all three as
"upgradable" to the phoebe release of Red Hat Linux !

Expected Results:  Only Red Hat Linux partitions should be listed as being
"upgradable".

Additional info:

Now maybe this is an invalid bug report because phoebe *can* actually
"upgrade" a Mandrake distro to Red Hat, but I didn't want to wreck
Mandrake to find out what happened :-) However, I think the end-user
would be very wary of such an upgradability claim (I'm sure things
live in different locations, even for distros that had their early
origins in Red Hat like Mandrake used to) and it just seems plain
wrong to wipe off a rival's distro and claim it's an upgrade rather
than a fresh install :-)

Comment 2 Michael Fulbright 2003-01-08 20:27:31 UTC
Thanks we will try to find a solution to this problem.

Comment 3 Jeremy Katz 2003-01-09 01:17:13 UTC
We now check for product name in /etc/redhat-release and allow an override by
booting with 'linux upgradeany'

Comment 4 Mike McLean 2003-01-27 22:47:46 UTC
Confirmed in phoebe public beta 2.
* by default filtration by redhat-release is performed
* the upgradeany option overrides this
* the release notes describes this behavior


Note You need to log in before you can comment on or make changes to this bug.