Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81076 - metacity-properties missing from metacity RPM
Summary: metacity-properties missing from metacity RPM
Keywords:
Status: CLOSED DUPLICATE of bug 79180
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-04 00:08 UTC by Richard Lloyd
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:54 UTC


Attachments (Terms of Use)

Description Richard Lloyd 2003-01-04 00:08:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
There is no /usr/bin/metacity-properties binary
in the phoebe beta release RPM of metacity
(metacity-2.4.8-1.i386.rpm).

Version-Release number of selected component (if applicable):
2.4.8-1

How reproducible:
Always

Steps to Reproduce:
1. Install the phoeba beta release, including metacity, of course
2. Log into the GNOME desktop
3. Select Main Menu -> Preferences -> Window Focus
    

Actual Results:  Error dialog returned by the above steps stating that
"metacity-properties" couldn't be run.

Expected Results:  In Red Hat 8.0, /usr/bin/metacity-properties is shipped in
the metacity RPM, so selecting the Window Focus menu item
in RH 8.0 runs metacity-properties, which brings
up a dialogue box allowing you change your window focus.

Additional info:

This looks like an RPM packaging mistake, because it does appear
that the phoebe beta expects metacity-properties to be installed
(rather than its functionality being incorporated into something
else).

I would say this is quite a major problem because the default of
clicking to focus is something I suspect a lot of users (me included !)
would want to change and they can't easily do it in phoebe.

The only "easy" workaround I had was to run metacity-properties in
phoebe from my 8.0's / (e.g. I mounted 8.0's / as /8.0 and then ran
/8.0/usr/bin/metacity-properties), but a user with only phoebe on
their system couldn't do this of course...

Comment 1 Bill Nottingham 2003-01-06 22:00:36 UTC

*** This bug has been marked as a duplicate of 79180 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.