Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81073 - gdm offers a lot of languages which are not installed
Summary: gdm offers a lot of languages which are not installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gdm
Version: phoebe
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 23:51 UTC by Peter van Egdom
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 17:39:04 UTC


Attachments (Terms of Use)

Description Peter van Egdom 2003-01-03 23:51:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
During installation I selected Dutch as default and English (USA) as additional
language. 

Pointing to the 'language' selection on gdm after booting Phoebe opens a large
window of all languages that Red Hat supports, which is odd because I only
installed Dutch and English. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. During installation, select only a couple of languages, e.g. Dutch & English.
2. After installation at the gdm screen, click on 'language'.
3.
    

Actual Results:  Notice that gdm offers all languages from A to Z

Expected Results:  Maybe gdm should only offer those languages which the user
chose during installation?

Additional info:

gdm-2.4.0.7-14

Red Hat Linux release 8.0.92 (Phoebe)

Comment 1 Havoc Pennington 2003-01-04 00:35:44 UTC
Hmm, I'm not sure this is a good idea; we don't really have a global concept of
"which languages are installed" - the selection in the installer only affects
those packages that the installer installs. You could still have a lot of stuff
installed that *did* support more languages, either because you did an upgrade,
or because you installed third-party packages. Also, I think we're changing it
so that you get all translations always, and the language choice is just for
your default language, though I could be wrong about that.



Comment 2 Havoc Pennington 2003-01-14 17:39:04 UTC
I confirmed that all languages will always be installed now, so 
I think this is no longer an issue.

It might be nice if you could configure what languages gdm offered; 
that enhancement request should really go to bugzilla.gnome.org.


Note You need to log in before you can comment on or make changes to this bug.