Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81058 - RHEL2.1: xemacs crashes with errata
Summary: RHEL2.1: xemacs crashes with errata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: xemacs
Version: 2.1
Hardware: ia64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL: st
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 22:02 UTC by Eric Schwartz
Modified: 2015-01-08 00:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-18 15:28:45 UTC


Attachments (Terms of Use)
crash log of starting 'xemacs' (deleted)
2003-01-03 22:02 UTC, Eric Schwartz
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:295 normal SHIPPED_LIVE Updated XEmacs packages fix startup segfault on Itanium 2004-08-18 04:00:00 UTC

Description Eric Schwartz 2003-01-03 22:02:01 UTC
Description of problem:
I installed AS2.1 from CD, then updated to the beta errata.  I then
tried to run xemacs from a GNOME session (I wanted to view info
pages), and I got the soon-to-be-attached crash.

Version-Release number of selected component (if applicable):
xemacs-21.4.6-6.7

How reproducible:
100%

Steps to Reproduce:
1. run 'xemacs' in a gnome terminal under X
2.
3.
    
Actual results:
Crashes

Expected results:
Doesn't crash.

Additional info:
I like pie.

Comment 1 Eric Schwartz 2003-01-03 22:02:32 UTC
Created attachment 89111 [details]
crash log of starting 'xemacs'

Comment 2 Jens Petersen 2003-01-04 02:32:29 UTC
Is a core dump file generated?



Comment 3 Eric Schwartz 2003-01-06 17:17:52 UTC
No core dump file is generated.

Comment 4 Jens Petersen 2003-05-19 07:56:55 UTC
Does it run ok for you in a tty ("xemacs -nw")?

Comment 5 Jens Petersen 2003-11-19 01:23:26 UTC
Nope.

Comment 6 Jens Petersen 2003-11-19 08:31:12 UTC
(Btw, just in case it wasn't obvious, the solution is just to rebuild
the srpm.)

Comment 7 Ville Skyttä 2003-11-19 19:14:29 UTC
Just a far-fetched hunch, but probably the core file isn't created
because of core files being disabled by default (on RHL that is, I
don't know about RHEL).  "ulimit -c unlimited" could help...

Comment 11 Jens Petersen 2004-05-18 12:10:37 UTC
We now have a workaround for this for ia64 (linking without
-dynamic-export) so this should be easy to fix for the next
updates release. :)

Comment 13 John Flanagan 2004-08-18 15:28:45 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-295.html



Note You need to log in before you can comment on or make changes to this bug.