Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81050 - network interface won't go up if negotiation takes too long (with patch)
Summary: network interface won't go up if negotiation takes too long (with patch)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-03 20:41 UTC by Alexandre Oliva
Modified: 2014-03-17 02:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 01:24:52 UTC


Attachments (Terms of Use)
patch that fixes /etc/sysconfig/network-scripts/network-functions (deleted)
2003-01-03 20:42 UTC, Alexandre Oliva
no flags Details | Diff

Description Alexandre Oliva 2003-01-03 20:41:45 UTC
If ip link says the interface is up but mii-tool says it's got no link before
negotiation is complete, ifup fails very quickly.  In 8.0, we used to wait 5
seconds between ip set up and running mii-tool, which was enough for my epic100
card to negotiate the link.  In Phoebe, it always fails, because there's a 1-2
second window between ip link reporting the interface is up and mii-tool getting
a `link ok'.  The patch I'm going to attach restores the 8.0 behavior, in that
it takes at most 5 seconds to bail out, but it gives more time for mii-tool to
return a success result.

Comment 1 Alexandre Oliva 2003-01-03 20:42:50 UTC
Created attachment 89107 [details]
patch that fixes /etc/sysconfig/network-scripts/network-functions

Comment 2 Bill Nottingham 2003-01-14 01:24:23 UTC
Fixed differently in 7.03-1.

Comment 3 Alexandre Oliva 2003-01-23 14:56:39 UTC
Confirmed fixed in phoebe2.


Note You need to log in before you can comment on or make changes to this bug.