Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81044 - htsearch only outputs up to a 4k boundary.
Summary: htsearch only outputs up to a 4k boundary.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: htdig
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
: 100461 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 18:42 UTC by Liberate
Modified: 2015-03-05 01:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-19 15:02:54 UTC


Attachments (Terms of Use)
This is the actual output from htsearch when redirected to a file. (deleted)
2003-01-03 18:46 UTC, Liberate
no flags Details
This is the expected output from htsearch. (deleted)
2003-01-03 18:48 UTC, Liberate
no flags Details
htdig.conf file used (deleted)
2003-01-03 18:49 UTC, Liberate
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:376 normal SHIPPED_LIVE Updated htdig packages fix truncated output problems 2003-12-19 05:00:00 UTC

Description Liberate 2003-01-03 18:42:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
htsearch(part of htdig) only outputs to apache or redirected to a file up to the
nearest 4K boundary.  I.e. If I run htsearch from a shell prompt I get 11K of
complete output, if I do the same search redirecting to a file or piping to
another command(more), I only get 8K of output.  This is the same behavior with
apache.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.htsearch 
2.put in search words
3.put in output form
    

Actual Results:  will attach actual output as actual.html

Expected Results:  will attach expected output as expected.html

Additional info:

Comment 1 Liberate 2003-01-03 18:46:36 UTC
Created attachment 89103 [details]
This is the actual output from htsearch when redirected to a file.

This is the actual output from htsearch when redirected to a file or executed
from apache.

Comment 2 Liberate 2003-01-03 18:48:08 UTC
Created attachment 89104 [details]
This is the expected output from htsearch.

This is the expected output from htsearch or when you run htsearch from the
shell prompt.

Comment 3 Liberate 2003-01-03 18:49:42 UTC
Created attachment 89105 [details]
htdig.conf file used

This is the configuration file associated with htsearch.

Comment 4 Jon Mitchiner 2003-05-28 20:36:28 UTC
Im having the same problem as this user.  This is a summary of an email I sent 
Phil.

$ /var/www/cgi-bin/htsearch "words=wordname"
I copied the output manually and pasted it to a file named 'firstout'.
 
$ ls -al firstout
-rw-r--r--    1 root     root         9292 May 28 15:48 firstout

Now I am attempting this with a pipe:
 
$ /var/www/cgi-bin/htsearch "words=wordname" > secondout
$ ls -al secondout
-rw-r--r--    1 root     root         8192 May 28 15:49 secondout


$ /var/www/cgi-bin/htsearch -vv "words=wordname" > thirdout 
$ ls -al thirdout
-rw-r--r--    1 root     root         7006 May 28 15:53 thirdout

As you can see the filesize shrinks when I add more debugging info.  It seems 
htsearch has a problem when it sends the data through a pipe.  




Comment 5 Jon Mitchiner 2003-05-31 00:45:16 UTC
I downloaded the source for the latest Htdig and it had the exact same 
problem.  Whenever I run htdig from the command line with a pipe then the 
above results will occur again.

I went back to the latest stable release (3.1.6) and compiled it.  It worked 
like a charm.

I do not understand why Redhat is releasing a beta copy of htdig with AS 2.1.  
I thought the whole purpose for AS 2.1 was to have solid stable software...

Comment 6 Brent Bourgoine 2003-07-22 18:34:03 UTC
Seeing the same issue here with 2.1AS and htdig 3.2x, with the addition of
failing searches producing an HTTP 500 error (see bug 100461).

Comment 7 Phil Knirsch 2003-09-02 12:54:57 UTC
I've downgraded htdig now for our next enterprise product again and i'm thinking
about doing a htdig-3.1.6 errata for AS2.1, too, but that might take some time
(we're pretty busy with the next enterprise product atm ;-).

If you want to you can give htdig-3.1.6-3 from Rawhide a try (rebuild from SRPM,
of course). If time permits i'll do a AS2.1 package and put it on
people.redhat.com in the next few days.

Thanks,

Read ya, Phil

Comment 8 Phil Knirsch 2003-09-02 13:53:36 UTC
*** Bug 89046 has been marked as a duplicate of this bug. ***

Comment 9 Phil Knirsch 2003-09-02 14:09:27 UTC
*** Bug 100461 has been marked as a duplicate of this bug. ***

Comment 10 Phil Knirsch 2003-10-28 13:10:59 UTC
OK, an AS2.1 update request has been opened via bugzilla:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=108180

Read ya, Phil

Comment 11 John Flanagan 2003-12-19 15:02:55 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-376.html



Note You need to log in before you can comment on or make changes to this bug.