Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81043 - Getting external firewire drives recognized repeatably.
Summary: Getting external firewire drives recognized repeatably.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 18:40 UTC by Stephen John Smoogen
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-14 06:31:39 UTC


Attachments (Terms of Use)

Description Stephen John Smoogen 2003-01-03 18:40:23 UTC
I am having some problems with getting a firewire drive to show up at
boot-time. I am not exactly sure what the problem is because it seems to
show up in the boot-process

ohci1394_0: OHCI-1394 1.0 (PCI): IRQ=[10]  MMIO=[fdfff800-fe000000]  Max 
Packet=[2048]
scsi0 : IEEE-1394 SBP-2 protocol driver (host: ohci1394)
SBP-2 module load options:
- Max speed supported: S400
- Max sectors per I/O supported: 255
- Max outstanding commands supported: 8
- Max outstanding commands per lun supported: 1
- Serialized I/O (debug): no
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 172k freed
ieee1394: sbp2: Logged into SBP-2 device
ieee1394: sbp2: Node[00:1023]: Max speed [S400] - Max payload [2048]
ieee1394: Device added: Node[00:1023]  GUID[0050c501e00b0f5a]  [ADS 
Technologies, Inc.  ]
ieee1394: Host added: Node[01:1023]  GUID[000108001001d26b]  [Linux 
OHCI-1394]

But then by the time for the mounting of the disks it seems to 
'disappear'. I think it might be during the usb module loading

usb-uhci.c: USB UHCI at I/O 0xff80, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 7 for device 00:1f.4
PCI: Setting latency timer of device 00:1f.4 to 64
usb-uhci.c: USB UHCI at I/O 0xff60, IRQ 7
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers

By the time the system gets to a login, doing a cat /proc/scsi/scsi 
shows

<4 glasya->smooge> cat /proc/scsi/scsi
Attached devices: none

I then need to do by hand a

[root@glasya smooge]# rmmod sbp2 ; rmmod ohci1394 ; rmmod sd_mod ; \
rmmod ieee1394 ; rmmod scsi_mod
[root@glasya smooge]# modprobe ohci1394

This causes the following kernel messages to be registered:

ieee1394: sbp2: Logged out of SBP-2 device
scsi : 0 hosts left.
ieee1394: Device removed: Node[00:1023]  GUID[0050c501e00b0f5a]  [ADS 
Technologies, Inc.  ]
ieee1394: Host removed: Node[01:1023]  GUID[000108001001d26b]  [Linux 
OHCI-1394]ohci1394: $Revision: 1.101 $ Ben Collins <bcollins@debian.org>
PCI: Found IRQ 10 for device 01:08.0
PCI: Sharing IRQ 10 with 00:1f.3
PCI: Sharing IRQ 10 with 00:1f.5
ohci1394_0: OHCI-1394 1.0 (PCI): IRQ=[10]  MMIO=[fdfff800-fe000000]  Max 
Packet=[2048]
ieee1394: Host added: Node[00:1023]  GUID[000108001001d26b]  [Linux 
OHCI-1394]
ieee1394: Device added: Node[01:1023]  GUID[0050c501e00b0f5a]  [ADS 
Technologies, Inc.  ]
SCSI subsystem driver Revision: 1.00
ieee1394: sbp2: Logged into SBP-2 device
ieee1394: sbp2: Node[01:1023]: Max speed [S400] - Max payload [2048]
scsi0 : IEEE-1394 SBP-2 protocol driver (host: ohci1394)
SBP-2 module load options:
- Max speed supported: S400
- Max sectors per I/O supported: 255
- Max outstanding commands supported: 8
- Max outstanding commands per lun supported: 1
- Serialized I/O (debug): no
  Vendor: WDC WD60  Model: 0BB-00CAA1        Rev:     
  Type:   Direct-Access                      ANSI SCSI revision: 06

At which point I can see the drive again in /proc/scsi/scsi.

I have changed the load order of modules in the initrd.img and done some 
cave man debug messages in /etc/rc.d/rc.sysinit to see where it 
'disappears' but havent gotten very far yet.

Any ideas on how i can debug this further?

-- 
Stephen John Smoogen
  smooge@mindspring.com

Comment 1 Stephen John Smoogen 2003-01-03 18:42:11 UTC
Ok I solved the problem with the firewire devices. The problem seems to        
be either with the order that they are inserted into the initrd.img by         
mkinitrd AND/OR the loading of them by initscripts rc.sysinit.                 
                                                                               
Here is how I debugged it.   
                                                                               
                                                   Commented out the lines in
/etc/rc.d/rc.sysinit and rebooted...                                           
                   
                                  no firewire device.                          
                          
                                                                               
        Kept the lines commented and reversed the order of insmod in the       
       
initrd's linuxrc file..                       
                                                                               
                                  firewire devices on reboot. sometimes... the
first reboot I had them..          the next I didnt.                              
                                                                               
                                 Added the lines back into /etc/rc.d/rc.sysinit.
                                              

no firewire devices on reboot. Second modprobe seems to confuse things.        
                                                                                

Removed the insmod lines from linuxrc                                          
                                                                                

firewire devices on reboot and EVERY reboot.                                   
                                                                                

I have put this against mkinitrd but figure that Devel/QA will put it in the
proper place.

Comment 2 Stephen John Smoogen 2003-01-03 18:43:39 UTC
One last thing.. this bug effects 7.3/8.0/and current beta from what I can tell.

Comment 3 Jeremy Katz 2003-01-06 06:07:33 UTC
If I'm following you correctly, then this is a kernel bug since the module load
order really shouldn't matter

Comment 4 Stephen John Smoogen 2003-02-14 06:31:39 UTC
This seems to be fixed in 8.0.93+rawhide.  I am going to close it as I can not
duplicate it anymore


Note You need to log in before you can comment on or make changes to this bug.