Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81037 - rhn-applet.-gui does not work
Summary: rhn-applet.-gui does not work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rhn-applet
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-03 17:06 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-05 12:00:53 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-03 17:06:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
It has really not worked since mid december (i.e. Raw Hide). A full phoebe
upgrade did not help, either. I've updated to latest Raw Hide of rhn*, pygtk2,
pyorbit, gnome-python2* and pygtk2, plus pythin, FWIW. The error it reports in
its current state is:

# rhn-applet-gui
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 16, in ?
    import rhn_utils
  File "/usr/bin/../share/rhn/rhn_applet/rhn_utils.py", line 17, in ?
    from rhn_applet_rpm import rhnAppletRPM
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpm.py", line 10, in ?
    import rpm
ImportError: /usr/lib/python2.2/site-packages/rpmmodule.so: undefined symbol:
rpmfiFColor

I've seen different problems earlier.

Also, there is no rhn_applet_gui in the gnome "Add to Panel" menu.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run rhn-applet-gui.

    

Additional info:

Version are:

rhnlib-1.0-1
rhn-applet-2.0.6-1

Comment 1 Need Real Name 2003-02-04 20:40:30 UTC
I have not actually seen it "working" (giving notification of new packages)
but in any case it is not stable. You can start 'rhn-applet-gui' and the
button appears on the panel and can be configured. But it does not survive
X restarts and reboots (the button disappears from the panel and does not
reappear later like the other icons/buttons).
After a new 'rhn-applet-gui' command two buttons appear on the panel.
The original (blue with tick mark) reappears and a new green one also appears.
This is on phoebe 2 with all the updates (up2date).


Comment 2 Daniel Veillard 2003-02-05 12:00:53 UTC
I cannot reproduce this:
 1/ installed beta 2, rhn-applet was missing from the comps file
    this is fixed now but as a result it wasn't installed by default.
 2/ I upgraded to the latest version using up2date
 3/ I installed rhn-applet using up2date
 4/ rebooted to get a fresh install as would have resulted from
    a clean install.

From there:
 5/ login in Gnome, the applet shows up in the panel, asking for 
    action (red blinking)
 6/ went through the couple of registration steps
 7/ then the applet made the network connection (green) for 20 secs
 8/ as no updates were needed it turned blue as expected.
 9/ logged out and relogged in to check the behaviour
10/ the applet started and kept blue as expected since no update are available

  Works for me !

Daniel


Comment 3 Need Real Name 2003-02-05 21:56:16 UTC
I did precisely the same as in your steps 1/, 2/, 3/ and 4/.
(except that I did not immediately reboot. I first finished some things I
was busy with and then shut down the laptop. The things I finished had nothing
to do with up2date or rhn or rhn-applet)
When I rebooted the next day and entered gnome the (red) rhn-applet did NOT
show up on the panel.
Looking around I discovered a curious (green) rhn-applet entry in 'System Tools'
with which you could do essentialy nothing.
So I started the rhn-applet from the command line (just like under RH-8.0
whenever it had accidentaly been removed from the panel).
This placed the applet on the panel but it was immediately the blue one.
And this one does not survive X restarts and reboots.
This doesn't sound like 100% correct behaviour to me.


Note You need to log in before you can comment on or make changes to this bug.