Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81035 - Config file contains invalid localized entries
Summary: Config file contains invalid localized entries
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-samba
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 16:46 UTC by Miloslav Trmac
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:29:38 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-01-03 16:46:08 UTC
Description of problem:
Demonstrated in LANG=cs_CZ.UTF-8 :
The authentication combo box contains "user" at start, but all
entries in the list are localized (UZIVATEL, SDILENI,...).
Similarly the encrypt passwords box below contains "no", but
provides choices ANO and NE.
When a change is made, the generated smb.conf contains
the *localized* strings, which are not valid values.
This prevents samba startup.

Comment 1 Brent Fox 2003-01-03 23:57:54 UTC
Oops.  I will look at this now.

Comment 2 Brent Fox 2003-01-04 01:56:58 UTC
I can't quite decide what is the correct thing to do.  I think that I could make
it so that the choices in the UI are translated but the English values would be
written to the file.  However, is that the correct thing to do?  As a user,
would you expect to see those options translated?

Comment 3 Brent Fox 2003-01-04 05:54:01 UTC
I've come up with a fix that makes the strings in the UI translated but the
values in the smb.conf file is in English.  I also replaced the GtkCombo widgets
with GtkOptionMenus, which is more correct.

Should be fixed in redhat-config-samba-1.0.0-4 in Rawhide.  QA, please verify.

Comment 4 Brent Fox 2003-05-25 14:29:38 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.


Note You need to log in before you can comment on or make changes to this bug.