Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81025 - behavior of select() on serial lines is different from vanilla kernel
Summary: behavior of select() on serial lines is different from vanilla kernel
Keywords:
Status: CLOSED DUPLICATE of bug 73376
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 16:08 UTC by giulioo
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:54 UTC


Attachments (Terms of Use)

Description giulioo 2003-01-03 16:08:00 UTC
Description of problem:
This problem is already in bug 73376, but since that one is public and seems to
be left alone, I'm filing this just as a reminder, close as you wish.

There seem to be a problem in select() and or serial line management, where
mgetty  is not notified something is using serial line; this way mgetty cannot
reset modem with init-chat after process terminates using serial line.

How reproducible:
always
1. have mgetty on the line
2. cu -l ttyS0, type some char
3. note how in log mgetty is still waiting for chars on ttyS0
4. terminate cu
5. note in mgetty log init-chat is not rerun

  
As reported in 73376, vanilla kernels are OK.

Comment 1 giulioo 2003-05-14 18:21:54 UTC

*** This bug has been marked as a duplicate of 73376 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.