Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81015 - radeon driver refuses to use dotclocks < 20Mhz
Summary: radeon driver refuses to use dotclocks < 20Mhz
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 82776
TreeView+ depends on / blocked
 
Reported: 2003-01-03 14:49 UTC by Nils Philippsen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-20 13:18:04 UTC


Attachments (Terms of Use)
Patch that ensures a minimum dotclock of >= 12.5 Mhz (deleted)
2003-02-10 15:40 UTC, Nils Philippsen
no flags Details | Diff
Patch implementing an option to force a specific minimum dotclock on Radeon cards (deleted)
2003-10-14 14:04 UTC, Nils Philippsen
no flags Details | Diff
Patch implementing an option to force a specific minimum dotclock on Radeon cards (deleted)
2003-10-27 14:03 UTC, Nils Philippsen
no flags Details | Diff

Description Nils Philippsen 2003-01-03 14:49:57 UTC
Description of problem:

When using the radeon driver, modelines with dotclocks of less than 20 Mhz are
ignored. Using a tweaked driver (from the .src.rpm) which ignores this
limitation, the card uses modelines with lower dotclocks without any hassles.

Version-Release number of selected component (if applicable):

XFree86-4.2.1-10.2

How reproducible:

Always

Steps to Reproduce:
1. Put a modeline with a dotclock < 20 Mhz into XF86Config, use it
    
Actual results:

Modeline gets ignored due to too low dotclock (according to /var/log/XFree86.*.log)

Expected results:

Modeline gets used or (if the card is lying about its capabilities) a
configuration option should exist which overrides the limitd determined by XFree86.

Comment 1 Mike A. Harris 2003-01-28 10:10:47 UTC
Sample modeline to reproduce?

Comment 2 Nils Philippsen 2003-01-28 11:14:59 UTC
Modeline "720x576" 13.875 720 744 808 888 576 582 588 625 -hsync -vsync
interlace # H 15625 [Hz], V 50 [Hz]

That's 720x576 PAL, let me know if you want an NTSC one -- I have some NTSC
modelines, but they're not tested.

Comment 3 Nils Philippsen 2003-02-10 15:40:56 UTC
Created attachment 89971 [details]
Patch that ensures a minimum dotclock of >= 12.5 Mhz

Do not use this at home kids. It might break your VGA card, your monitor or
even more.

Seriously: This patch forces the driver to use a minimum dotlock of 12.5 Mhz
(or less). I don't know if there are any Radeons that can't handle that (mine
does) and how they would react in that case. This should preferably be a
configuration option ('Option "EnsureTVDotClocks" "yes"'? -- we might have to
ensure that the max dotclock is at minimum 17.5 Mhz -- yeah right :o)), but I
don't know how to implement such options and I'm currently to busy/lazy to
figure out.

Comment 4 Mike A. Harris 2003-02-10 18:44:39 UTC
This type of thing would be a feature enhancement, and not really a bug
fix.  Due to the potentially hardware-damaging nature of such a change,
I won't consider something like this for our current development.  It's
IMHO something that should be requested upstream in order to be given
wider coverage.

Setting to DEFERRED

Comment 5 Nils Philippsen 2003-10-14 14:04:50 UTC
Created attachment 95161 [details]
Patch implementing an option to force a specific minimum dotclock on Radeon cards

This patch implements the "ForceMinDotclockenstein" option in the Radeon
driver. It accepts a frequency as its argument (like in "12.5Mhz"). This patch
documents the option in the radeon man page.

Comment 6 Nils Philippsen 2003-10-27 14:03:25 UTC
Created attachment 95511 [details]
Patch implementing an option to force a specific minimum dotclock on Radeon
cards

Revised patch as suggested by Kevin Martin:

- rename option to "ForceMinDotClock"
- fix code duplication

Comment 7 Nils Philippsen 2003-10-27 14:04:54 UTC
File this patch upstream, deferred.

Comment 8 Nils Philippsen 2004-04-20 13:17:29 UTC
Fixed in xorg-x11-6.7.0-0.5.


Note You need to log in before you can comment on or make changes to this bug.