Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81001 - Apparent locale problem with python scripts
Summary: Apparent locale problem with python scripts
Keywords:
Status: CLOSED DUPLICATE of bug 76104
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 08:30 UTC by Rick Stevens
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:53 UTC


Attachments (Terms of Use)

Description Rick Stevens 2003-01-03 08:30:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
An attempt to run either redhat-config-printer or redhat-config-soundcard
results in python errors:

------------------------------ CUT HERE -----------------------------
[root@xyclone etc]# redhat-config-soundcard
Traceback (most recent call last):
  File "/usr/share/redhat-config-soundcard/redhat-config-soundcard.py", line 31,
in ?
    from rhpl.translate import _, N_
  File "/usr/lib/python2.2/site-packages/rhpl/translate.py", line 197, in ?
    cat = i18n()
  File "/usr/lib/python2.2/site-packages/rhpl/translate.py", line 75, in __init__
    self.setDomain(domain)
  File "/usr/lib/python2.2/site-packages/rhpl/translate.py", line 134, in setDomain
    self.iconv = iconv.open(self.codeset, encoding)
ValueError: (22, 'Invalid argument')
------------------------------ CUT HERE -----------------------------
Current setting of LANG environment variable is "en_US.UTF-8".

This system was updated from 7.2 to 8.0, it is not a fresh install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up the system into GUI mode
2. Log in as root
3. run "redhat-config-printer" or "redhat-config-soundcard"
    

Actual Results:  Python errors as described above

Expected Results:  I would imagine the GUI or command-line config utility would
run.  As it stands, I've had to run CUPS to configure my printer and I can't
configure my soundcard.

Additional info:

To be honest, don't you think using python for this sort of thing is a bit
silly?  Python is undoubtedly the most cryptic language I have ever seen, and I
worked on LISP systems for 10 years.

Comment 1 Jeremy Katz 2003-01-06 16:21:32 UTC

*** This bug has been marked as a duplicate of 76104 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.