Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80997 - "Random" font changes in sawfish configurator
Summary: "Random" font changes in sawfish configurator
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: sawfish
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
: 75331 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 03:52 UTC by Michal Jaegermann
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 04:04:13 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2003-01-03 03:52:33 UTC
Description of problem:

Results of picking up new fonts in sawfish-ui are quite unpredictable.
It appears that this is because it writes to ~/.sawfish/custom
strings like:

"-*-URW Bookman L,-bold-*-*-*-13-*-*-*-*-*-*-*"

while something like this

"-urw-bookman l-demi bold-r-*-*-*-*-*-*-*-*-*-*"

seems to be rather expected.  At least 'xfontsel' will produce something
of that kind.

Even if fonts do change on a display (sometimes they do) results can
be strange and unpredictable.  In particular font selector drops "-r-" strings
so what you are getting may end up in italics (or will not have any effect at
all).

Comment 1 Havoc Pennington 2003-01-13 04:04:13 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103329


Comment 2 Havoc Pennington 2003-01-13 04:44:20 UTC
*** Bug 75331 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.