Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80991 - redhat-config-network crashes when trying to configure internet
Summary: redhat-config-network crashes when trying to configure internet
Keywords:
Status: CLOSED DUPLICATE of bug 80935
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 02:26 UTC by Venkat Krishnaswamy
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:53 UTC


Attachments (Terms of Use)

Description Venkat Krishnaswamy 2003-01-03 02:26:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021228

Description of problem:
Internet Configuration wizard crashes. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run Internet Configuration Wizard from GNOME.
2.
3.
    

Additional info:

Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareFactory.py:42:getHardwareClass:
KeyError: Wireless

Traceback (most recent call last):
  File "/usr/sbin/internet-druid", line 93, in ?
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 84, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 95, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 52, in __init__
    self.hardwarelist = NCHardwareList.getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 389, in getHardwareList
    HWList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 202, in load
    i = self.addHardware(type)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 134, in addHardware
    hwc = hwf.getHardwareClass(type)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareFactory.py", line
42, in getHardwareClass
    return self[type][0]
KeyError: Wireless

Local variables in innermost frame:
subtype: None
self: {'Ethernet': {0: <class netconfpkg.NCHWEthernet.HwEthernet at 0x838bb0c>},
'Modem': {0: <class netconfpkg.NCHWModem.HwModem at 0x838c2d4>}, 'ISDN': {0:
<class netconfpkg.NCHWIsdn.HwIsdn at 0x833d50c>}, 'Token Ring': {0: <class
netconfpkg.NCHWTokenring.HwTokenring at 0x81d48a4>}}
type: Wireless

Comment 1 Harald Hoyer 2003-01-09 13:39:18 UTC

*** This bug has been marked as a duplicate of 80935 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.