Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80990 - httpd causes kernel oops in sys_semop
Summary: httpd causes kernel oops in sys_semop
Keywords:
Status: CLOSED DUPLICATE of bug 80275
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-03 00:39 UTC by H. Peter Anvin
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:53 UTC


Attachments (Terms of Use)
dmesg extract of oops (deleted)
2003-01-03 00:40 UTC, H. Peter Anvin
no flags Details
ksymoops output for oops info (deleted)
2003-01-03 00:41 UTC, H. Peter Anvin
no flags Details

Description H. Peter Anvin 2003-01-03 00:39:42 UTC
When starting RedHat 8.1 beta Phoebe on a dual P3 system, httpd causes an oops
in the kernel.  After that point, the machine continues to work, but httpd is
stuck in the kernel, unkillable, consuming 100% of one CPU (/proc/pid/cpu
confirms it is locked down on one CPU, it doesn't alternate.)

This is a stock build kernel, and the machine has 1 GB of RAM:

: neocesium 129 # uname -a
Linux neocesium 2.4.20-2.2smp #1 SMP Fri Dec 20 12:36:15 EST 2002 i686 i686 i386
GNU/Linux
: neocesium 130 # cat /proc/version
Linux version 2.4.20-2.2smp (bhcompile@stripples.devel.redhat.com) (gcc version
3.2.1 20021207 (Red Hat Linux 8.0 3.2.1-2)) #1 SMP Fri Dec 20 12:36:15 EST 2002
: neocesium 131 # cat /proc/meminfo
        total:    used:    free:  shared: buffers:  cached:
Mem:  1054924800 396193792 658731008        0  4771840 210534400
Swap: 2097434624 70729728 2026704896
MemTotal:      1030200 kB
MemFree:        643292 kB
MemShared:           0 kB
Buffers:          4660 kB
Cached:         136528 kB
SwapCached:      69072 kB
Active:         188860 kB
ActiveAnon:     129612 kB
ActiveCache:     59248 kB
Inact_dirty:     27528 kB
Inact_laundry:  109684 kB
Inact_clean:      5012 kB
Inact_target:    66216 kB
HighTotal:      131072 kB
HighFree:         1024 kB
LowTotal:       899128 kB
LowFree:        642268 kB
SwapTotal:     2048276 kB
SwapFree:      1979204 kB
Committed_AS:   399272 kB
: neocesium 132 # cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 851.955
cache size      : 256 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 mmx fxsr sse
bogomips        : 1697.38

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 851.955
cache size      : 256 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 mmx fxsr sse
bogomips        : 1697.38

: neocesium 133 #

Comment 1 H. Peter Anvin 2003-01-03 00:40:42 UTC
Created attachment 89078 [details]
dmesg extract of oops

Comment 2 H. Peter Anvin 2003-01-03 00:41:07 UTC
Created attachment 89079 [details]
ksymoops output for oops info

Comment 3 Bill Nottingham 2003-01-03 02:09:26 UTC

*** This bug has been marked as a duplicate of 80275 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.