Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80978 - [RFE] build with GnuPG support through GPGME
Summary: [RFE] build with GnuPG support through GPGME
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: sylpheed
Version: 1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
: 114293 124868 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 23:09 UTC by Michael Schwendt
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-30 12:04:10 UTC


Attachments (Terms of Use)
proposed spec changes/fixes (deleted)
2004-01-29 11:00 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2003-01-02 23:09:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Request for enhancement:

Sylpheed should be built with GPGME (GnuPG Made Easy) which is not available in
the distribution, unfortunately. That would activate security/privacy features
in Sylpheed like GnuPG/PGP signatures and encryption.

Comment 1 Akira TAGOH 2003-04-21 08:59:24 UTC
GPGME is now alpha version product. so I set the priority to low.

Comment 2 Akira TAGOH 2004-01-28 05:27:55 UTC
*** Bug 114293 has been marked as a duplicate of this bug. ***

Comment 3 Andrew D Kirch 2004-01-29 07:28:28 UTC
would you consider adding support for detecting it to the SPEC file so
it can be rebuilt?

Comment 4 Akira TAGOH 2004-01-29 08:23:01 UTC
That's so easy :)

Comment 5 Michael Schwendt 2004-01-29 11:00:18 UTC
Created attachment 97327 [details]
proposed spec changes/fixes

How about this?

* Thu Jan 29 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 0.9.8a-2
- Add conditional GPGME support (--with gpg).
- Add desktop menu entry using desktop-file-utils.
- Fix up build requirements and very moderate spec cleanup.
- Obsolete included icon file (Source1).

Comment 6 Akira TAGOH 2004-01-29 11:20:15 UTC
already done and will be available soon. though it just provides the
option for the build, is it worth closing bug?

Comment 7 Michael Schwendt 2004-01-29 11:50:34 UTC
There you're asking the wrong one. ;)  Bill Nottingham seems to think
GPGME is not ready [yet], and I'm using my own Sylpheed package
anyway. But it's okay with me if you would close this as DEFERRED.

Though, please have a look at my patch nevertheless. E.g. your package
strip-installs, which it shouldn't do.


Comment 8 Michael Schwendt 2004-01-29 11:52:33 UTC
Oops, what was that?

Comment 9 Michael Schwendt 2004-01-29 11:54:00 UTC
[Oh, only examing the combobox next to "Resolve bug, changing
resolution to..." selects the radio buttons next to it, too. D'oh!]

Comment 10 Akira TAGOH 2004-01-30 10:17:38 UTC
ah, right. we shouldn't do strip. I'll fix it then. thanks.

Comment 11 Akira TAGOH 2004-01-30 12:04:10 UTC
Ok, we still have a possibility to include gpgme to core, but it's
still work in progress. so closing this. if it's time to include gpgme
to core, repoen or file it again.

Comment 12 Akira TAGOH 2004-06-01 00:56:24 UTC
*** Bug 124868 has been marked as a duplicate of this bug. ***

Comment 13 Ben Escoto 2004-06-01 01:46:40 UTC
A bit off-topic: is there some place to vote for whether packages like
gpgme make it to core?  Who decides and on what basis?  Thanks.

Comment 14 Akira TAGOH 2004-06-01 05:34:25 UTC
Nope. please file a bug to the distrubition or ask on the mailing list
when it's time to go.

Comment 15 Michael Schwendt 2004-06-01 12:40:03 UTC
It is unlikely to happen until GPGME is stabilized and applications
used the more recent API. At least, GPGME in Core would not buy you
GPG support in Sylpheed. Sylpheed (and Sylpheed Claws) still depend on
the old GPGME 0.3.x and its different API while other applications use
the newer GPGME 0.4.x. Having packages 'gpgme03' and 'gpgme' (like
fedora.us do it) in Fedora Core would work, but I understand that it
would be better to have a single version which can be kept current.

Comment 16 Craig Routledge 2004-07-05 22:20:26 UTC
I just got word from one of the GPGME developers (thanks Marcus
Brinkmann) that with the recent 0.9 release the API should be
stabilized and they are moving towards a 1.0 release now.

Balsa should be doing a new (2.0.18) stable release real soon.  It
would be nice to get GPGME in so that the new release could be built
with signing support before FC3 starts freezing up.  I assume Sylpheed
would not be far behind in synchronizing up with 0.9, but I haven't
spoken with them.


Comment 17 Craig Routledge 2004-07-07 01:54:28 UTC
triage->version to 2, possibly reopen pending decision for FC3



Note You need to log in before you can comment on or make changes to this bug.