Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80976 - redhat-config-bind crashes when doing help --> about
Summary: redhat-config-bind crashes when doing help --> about
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-bind
Version: phoebe
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-02 22:08 UTC by Peter van Egdom
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 15:38:10 UTC


Attachments (Terms of Use)

Description Peter van Egdom 2003-01-02 22:08:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Bringing up the 'about' window of "redhat-config-bind" crashes the program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start "redhat-config-bind"
2. do help --> about
3.
    

Actual Results:  program crashes.

Expected Results:  program should've shown the about window.

Additional info:


This gets returned to the shell, if started from an xterm :

(redhat-config-bind:14615): GLib-GObject-WARNING **: invalid cast from `(null)'
to `GtkObject'

dlopen failed on 'libthread_db.so.1' - /lib/i686/libthread_db.so.1: undefined
symbol: ps_get_thread_area
GDB will not be able to debug pthreads.

"/usr/sbin/redhat-config-bind": not in executable format: File format not recognized




And this is the traceback generated by Bug Buddy :

Backtrace was generated from '/usr/sbin/redhat-config-bind'

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x4003ebc2 in waitpid () from
/lib/i686/libpthread.so.0
#0  0x4003ebc2 in waitpid () from /lib/i686/libpthread.so.0
#1  0x40d0e2e5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x400cd320 in g_dataset_destroy () from /usr/lib/libglib-2.0.so.0
#4  0x400cd71a in g_datalist_id_set_data_full () from /usr/lib/libglib-2.0.so.0
#5  0x4009138d in g_object_class_list_properties () from
/usr/lib/libgobject-2.0.so.0
#6  0x402e3ed3 in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x403c1fc2 in gtk_widget_get_default_direction () from
/usr/lib/libgtk-x11-2.0.so.0
#8  0x403c79fc in _gtk_window_reposition () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x4009169e in g_object_class_list_properties () from
/usr/lib/libgobject-2.0.so.0
#10 0x40028eeb in pygobject_dealloc ()
   from /usr/lib/python2.2/site-packages/gtk-2.0/gobjectmodule.so
#11 0x080c2989 in frame_dealloc ()
#12 0x0807ad17 in PyEval_EvalCodeEx ()
#13 0x080c429c in function_call ()
#14 0x080b35b7 in PyObject_Call ()
#15 0x0807bed0 in PyEval_CallObjectWithKeywords ()
#16 0x080b356e in PyObject_CallObject ()
#17 0x40027ba5 in pyg_closure_marshal ()
   from /usr/lib/python2.2/site-packages/gtk-2.0/gobjectmodule.so
#18 0x4008ee17 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#19 0x400a2016 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#20 0x400a1268 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#21 0x400a1494 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#22 0x403bc07d in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x402d5e92 in gtk_menu_shell_activate_item () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x402d4f21 in _gtk_menu_shell_activate () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x402cd0bd in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x402c352c in _gtk_marshal_BOOLEAN__BOXED () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x4008f187 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#28 0x4008ee17 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#29 0x400a1b6c in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#30 0x400a106f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#31 0x400a1494 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#32 0x403bbe7e in gtk_widget_send_expose () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x402c32e4 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#34 0x402c1e4a in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#35 0x4049dd05 in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#36 0x400dd7d5 in g_get_current_time () from /usr/lib/libglib-2.0.so.0
#37 0x400de678 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#38 0x400de98d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#39 0x400df08f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#40 0x402c166f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#41 0x4019fbcc in _wrap_gtk_main ()
   from /usr/lib/python2.2/site-packages/gtk-2.0/gtk/_gtkmodule.so
#42 0x0807c146 in fast_cfunction ()
#43 0x0807a234 in eval_frame ()
#44 0x0807acce in PyEval_EvalCodeEx ()
#45 0x0807c22b in fast_function ()
#46 0x0807a1a3 in eval_frame ()
#47 0x0807acce in PyEval_EvalCodeEx ()
#48 0x08077bc5 in PyEval_EvalCode ()
#49 0x08097a69 in run_node ()
#50 0x080969d0 in PyRun_SimpleFileExFlags ()
#51 0x0809631a in PyRun_AnyFileExFlags ()
#52 0x080539f9 in Py_Main ()
#53 0x08053449 in main ()
#54 0x42015970 in __libc_start_main () from /lib/i686/libc.so.6

Comment 1 Daniel Walsh 2003-01-06 20:40:02 UTC
This is a problem caused by other parts of the system.  It will be fixed in the
next beta.

Comment 2 Jay Turner 2003-01-14 15:38:10 UTC
I'm no longer seeing this problem with a full re0113.0 installation (including
redhat-config-bind-1.9.0-10)


Note You need to log in before you can comment on or make changes to this bug.