Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80973 - Backtrace was generated from '/usr/bin/xchat' during buffer search
Summary: Backtrace was generated from '/usr/bin/xchat' during buffer search
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xchat
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 21:53 UTC by Ted Kaczmarek
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 16:09:47 UTC


Attachments (Terms of Use)
backtrace from crash (deleted)
2003-01-02 21:54 UTC, Ted Kaczmarek
no flags Details

Description Ted Kaczmarek 2003-01-02 21:53:18 UTC
Description of problem:Xchat crashed when searching buffer


Version-Release number of selected component (if applicable):
xchat-1.8.10-8


How reproducible:Only once, but will try to reproduce


Steps to Reproduce:
1.Start xchat,connect to irc.freenode.net
2.enter channel redhat
3.after 30 minutes or so search buffer, after completes, click search again
    
Actual results:Crashes


Expected results:Search


Additional info:

Comment 1 Ted Kaczmarek 2003-01-02 21:54:02 UTC
Created attachment 89075 [details]
backtrace from crash

Comment 2 Ted Kaczmarek 2003-01-02 23:49:57 UTC
Not easy to reproduce.

Comment 3 Mike A. Harris 2003-01-12 02:31:40 UTC
Please try xchat 1.8.11-3 in rawhide.  It might fix this problem.

Does it seem to work for you?

Comment 4 Ted Kaczmarek 2003-01-12 16:19:12 UTC
[root@nitremb21 rpms]# rpm -Uvh xchat-1.8.11-3.i386.rpm
error: Failed dependencies:
        libcrypto.so.4 is needed by xchat-1.8.11-3
        libpthread.so.0(GLIBC_2.3.2) is needed by xchat-1.8.11-3
        libssl.so.4 is needed by xchat-1.8.11-3
[root@nitremb21 rpms]#

Really don't feel like polluting this box, don't presently have an 8.0 available
to risk resolving all the deps. Would a test on Phoebe be of use?

Comment 5 Mike A. Harris 2003-01-23 00:36:25 UTC
Yes, you can use phoebe, or you could rebuild the phoebe src.rpm on an 8.0
box.  I'm unable to reproduce this problem in xchat 1.8.10 or 1.8.11
personally.  Setting bug state to MODIFIED.

Please set to ASSIGNED if problem recurs, or to RAWHIDE if 1.8.11
resolves the problem for you after testing as per above.

Thanks.


Comment 6 Brent Fox 2003-05-25 16:09:47 UTC
Looks like it works to me.  Closing as Currentrelease since the Xchat in RHL9
seems to work.


Note You need to log in before you can comment on or make changes to this bug.