Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80948 - glibc-2.3.1-26 segfaults
Summary: glibc-2.3.1-26 segfaults
Keywords:
Status: CLOSED DUPLICATE of bug 81734
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc
Version: 1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-02 19:03 UTC by Sammy
Modified: 2016-11-24 15:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:51 UTC


Attachments (Terms of Use)

Description Sammy 2003-01-02 19:03:53 UTC
The latest glibc results in everything segfaulting in the system with only 
way to recover being to boot from CD and tar glibc file from another system 
and bring it over. Is something else needs to be upgraded in rawhide like 
the kernel to include support for this glibc? I have everything elsed synced 
with Jan.2 rawhide release.

Comment 1 Igor V. Kovalenko 2003-01-03 11:53:28 UTC
Do you have i686 version installed?
I have glibc-2.3.1-26.i686.rpm installed and it prevents most apps from running.
rpm complains about DB_PRIVATE, X does not start and such
I tried mv /lib/tls /lib/tls- and the system is usable now. TLS bug?
 

Comment 2 Sammy 2003-01-03 14:34:08 UTC
Hmmm, that is interesting about tls, I may try it too or perhaps -27 fixes it. 
 
Rpm solution was reported in another bug report we opened, the solution is 
to create a file /etc/rpm/macros and put a line into it: 
 
%__dbi_cdb create private cdb mpool mp_mmapsize=16Mb mp_size=1Mb 
 
this solves the PRIVATE problem. 

Comment 3 Jakub Jelinek 2003-01-03 14:49:56 UTC
You either need to run the kernel provided in Phoebe or other with the threading
backport patches, or 2.5.5x (already at the time you upgrade glibc),
or you have to run kernels <= 2.4.19 where ld.so automatically detects this
and uses the old threading library and no TLS.
What exact kernel are you running?

Comment 4 Sammy 2003-01-03 14:56:54 UTC
I am running: 
 
kernel-2.4.20-2.2 
kernel-doc-2.4.20-2.2 
kernel-source-2.4.20-2.2 
 
Essentially all packages are in sync with the current rawhide 

Comment 5 Sammy 2003-01-03 16:25:15 UTC
I just tested glibc-2.3.1-27 and had the same problem. All other packages are in 
sync with today's (1/3/03) packages. 

Comment 6 Sammy 2003-01-03 17:29:13 UTC
Is there a conflict in the specfile with the  nptlarches and withtlsarches for i686 arch. 
The first time gcc flags are defined we have, because of withtlsarches,  
                   WithTls="--with-tls --without-__thread" 
The second time around nptlarches is the main if block and sets 
                   WithTls="--with-tls --with-__thread" 
and the withtlsarches block does not execure since it is in else directive. 

Comment 7 Sammy 2003-01-06 20:50:45 UTC
I just installed glibc-2.3.1-30 with kernel-2.4.20-2.6, which when  I look at the 
patches includes the threading backport patch, still segfaults everything on the  
system. Do I really have to go to the Phoebe kernel to get this to work, which 
I do not want to do because of drm support for X? Thanks 

Comment 8 Sammy 2003-01-08 16:59:39 UTC
I am really buffled by this: I am using Phoebe kernel (also tried 2.6) and installing 
glibc-2.3.1-32: 
 
# rpm -Uvh glibc* 
Preparing...                ########################################### 
[100%] 
   1:glibc-common           ########################################### [ 
33%] 
   2:glibc                  ########################################### [ 
67%] 
error: %post(glibc-2.3.1-32) scriptlet failed, exit status 1 
error: %pre(glibc-devel-2.3.1-32) scriptlet failed, exit status 0 
error:   install: %pre scriptlet failed (2), skipping glibc-devel-2.3.1-32 
 
than everything gives Segmentation fault! I have to restart from 8.0 CD and reinstall 
glibc-2.3.1-21. I see other people using these glibc's, what is my problem? I am  
synced with rawhide and started from phoebe. 
 

Comment 9 Sammy 2003-01-15 15:53:00 UTC

*** This bug has been marked as a duplicate of 81734 ***

Comment 10 Red Hat Bugzilla 2006-02-21 18:50:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.