Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80931 - XTerm drops hyphens in man pages
Summary: XTerm drops hyphens in man pages
Keywords:
Status: CLOSED DUPLICATE of bug 80030
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 15:05 UTC by J. J. Ramsey
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:51 UTC


Attachments (Terms of Use)

Description J. J. Ramsey 2003-01-02 15:05:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If I try to view a man page in XTerm, most of the hyphens, especially those that
are part of option flags (i.e. -f or --foo) are invisible.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type "man less" in an XTerm
2. Scroll down to the OPTIONS section.

    

Actual Results:  The hyphens in the options flags are replaced by spaces.

Expected Results:  The hyphens in the options flags should be visible.

Additional info:

This seems to be a UTF-8 issue. If NROFF in /etc/man.config is changed to
"/usr/bin/nroff -c -Tlatin1 -mandoc", the problem goes away.

gnome-terminal is not affected by this bug.

Comment 1 Michael Lee Yohe 2003-01-02 16:20:37 UTC
See Bug 80030 for a solution.  I have also filed Bug 80936 as a feature request.

Comment 2 Mike A. Harris 2003-01-07 14:08:17 UTC

*** This bug has been marked as a duplicate of 80030 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.