Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8093 - Y2K BUG: uptime wrong after entering january 1st 00h00
Summary: Y2K BUG: uptime wrong after entering january 1st 00h00
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: clock
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-31 23:13 UTC by bernard
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-04 17:08:37 UTC


Attachments (Terms of Use)

Description bernard 1999-12-31 23:13:55 UTC
Hi there.

I've many computers running 6.1. The move to 01/01/00 went fine. The only
thing that I saw so far is that 'uptime' reports a 1 day uptime at 00h00,
and then a count of minutes starting at 00h00. For instance, if the
computer has been started 10 days ago, at 00h15, 'uptime' will say
'15 minutes'.

Top(1) reports the same wrong uptime so I guess it is not uptime(1) that
is wrong itself.

However everything seems ok. I continue to test...

Comment 1 Jeff Johnson 2000-01-04 17:08:59 UTC
I cannot reproduce either the uptime or top problem on sparc or i386 ~6.1
(i.e. mostly upgraded to Raw Hide) Red Hat Linux.


Note You need to log in before you can comment on or make changes to this bug.