Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80914 - rpm crashes with segmentation fault
Summary: rpm crashes with segmentation fault
Keywords:
Status: CLOSED DUPLICATE of bug 80912
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 10:02 UTC by Mario Mikocevic
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:51 UTC


Attachments (Terms of Use)

Description Mario Mikocevic 2003-01-02 10:02:51 UTC
Description of problem:
After upgrading rpm from 4.2-0.28 to 4.2-0.48 I cannot upgrade several packages,
rpm crashes with segmentation fault (sig11)

How reproducible:
Always

Steps to Reproduce:
1. upgrade rpm to latest rawhide
2. rpm -Uvh glibc-common-2.3.1-26.i386.rpm
*crash*
    
Actual Results:
 zsh: segmentation fault (core dumped)  rpm -Uvh glibc-common-2.3.1-26.i386.rpm

Additional info:

(gdb) where
#0  0x4010fb3f in memcpy () from /lib/libc.so.6
#1  0x080794e3 in strcpy ()
#2  0x08081e48 in strcpy ()
#3  0x080820f3 in strcpy ()
#4  0x0805e29c in strcpy ()
#5  0x0807b54d in strcpy ()
#6  0x08052c7f in strcpy ()
#7  0x400b270d in __libc_start_main () from /lib/libc.so.6

Comment 1 Reuben Farrelly 2003-01-02 12:31:54 UTC
Observing same behaviour here with glibc-common, can confirm the problem, and 
that the file is being transferred from the server properly as the byte counts 
match exactly.

I really just wanted to be added to the CC list for this bug report.  Does the 
new bugzilla not allow this without adding a comment?  Seems like this useful 
functionality has gone away from the old version...   [dkl@redhat.com, I've 
added you to the CC for this bug so that you get this mail as I note you are 
the person bugzilla reports seem to get assigned to]


Comment 2 Nils Philippsen 2003-01-02 13:08:29 UTC

*** This bug has been marked as a duplicate of 80912 ***

Comment 3 Sammy 2003-01-02 16:31:26 UTC
Well, everyting segfaults with the glibc -26, the system is hosed and unusable, I had 
to reboot from RedHat 8.0 CD, start network, tar glibc from another system and 
install it here, in order to make it usable again. What is the deal? 

Comment 4 Olivier Baudron 2003-01-02 16:40:59 UTC
Same here. Dig segfaults, rpm segfaults, mozilla does not start, etc...
I switched back to glibc*-2.3.1-6.

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.