Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80912 - rpm crashes trying to upgrade to glibc-common-2.3.1-26 from 2.3.1-25
Summary: rpm crashes trying to upgrade to glibc-common-2.3.1-26 from 2.3.1-25
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: rpm
Version: beta1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
: 80911 80914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 09:21 UTC by Nils Philippsen
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-02 15:44:29 UTC


Attachments (Terms of Use)
Bzipped coredump of rpm trying to install glibc-common-2.3.1-26.i386.rpm (deleted)
2003-01-02 09:31 UTC, Nils Philippsen
no flags Details
gdb backtrace of the coredump with rpm-debuginfo installed (deleted)
2003-01-02 09:36 UTC, Nils Philippsen
no flags Details

Description Nils Philippsen 2003-01-02 09:21:18 UTC
Description of problem:

As the subject says, when I try to upgrade to glibc-common-2.3.1-26 (from -25),
rpm segfaults even before finishing dependency checks:

[root@cognac 8.0.1]# rpm -Fvh glibc/2.3.1-26/i686/glibc-2.3.1-26.i686.rpm \
glibc/2.3.1-26/i686/glibc-debuginfo-2.3.1-26.i686.rpm \
glibc/2.3.1-26/i686/nptl-devel-2.3.1-26.i686.rpm \
glibc/2.3.1-26/i386/glibc-common-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-debug-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-devel-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-profile-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-utils-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/nscd-2.3.1-26.i386.rpm
Segmentation fault
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i686/glibc-2.3.1-26.i686.rpm
error: Failed dependencies:
        glibc-common = 2.3.1-26 is needed by glibc-2.3.1-26
        glibc = 2.3.1-25 is needed by (installed) glibc-debug-2.3.1-25
        glibc = 2.3.1-25 is needed by (installed) glibc-utils-2.3.1-25
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-common-2.3.1-26.i386.rpm
Segmentation fault
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-debug-2.3.1-26.i386.rpm
error: Failed dependencies:
        glibc = 2.3.1-26 is needed by glibc-debug-2.3.1-26
        glibc-devel = 2.3.1-26 is needed by glibc-debug-2.3.1-26
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-devel-2.3.1-26.i386.rpm
error: Failed dependencies:
        glibc-devel = 2.3.1-25 is needed by (installed) glibc-debug-2.3.1-25

Version-Release number of selected component (if applicable):

rpm-4.2-0.48 (happened with -0.46 also)

How reproducible:

Always

Steps to Reproduce:
1. See above
    
Actual results:

rpm segfaults trying to install glibc-common-2.3.1-26

Expected results:

rpm installs packages or complains about unsatisfied dependencies

Comment 1 Nils Philippsen 2003-01-02 09:31:16 UTC
Created attachment 89048 [details]
Bzipped coredump of rpm trying to install glibc-common-2.3.1-26.i386.rpm

Comment 2 Nils Philippsen 2003-01-02 09:36:21 UTC
Created attachment 89049 [details]
gdb backtrace of the coredump with rpm-debuginfo installed

Comment 3 Nils Philippsen 2003-01-02 09:40:02 UTC
*** Bug 80911 has been marked as a duplicate of this bug. ***

Comment 4 Nils Philippsen 2003-01-02 10:25:33 UTC
Same thing with XFree86-devel-4.2.99.3-20021230.0.i386.rpm (from
XFree86-devel-4.2.99.2-0.20021217.0)

Comment 5 Nils Philippsen 2003-01-02 12:57:29 UTC
This seems to have been introduced with release 0.45:

[root@cognac 8.0.1]# rpm -q rpm
rpm-4.2-0.45
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-common-2.3.1-26.i386.rpm
                                                                               
Segmentation fault
[root@cognac 8.0.1]# rpm -Uvh --oldpackage rpm/4.2-0.44/i386/*
Preparing...                ########################################### [100%]
   1:popt                   ########################################### [ 17%]
   2:rpm                    ########################################### [ 33%]
   3:rpm-build              ########################################### [ 50%]
   4:rpm-debuginfo          ########################################### [ 67%]
   5:rpm-devel              ########################################### [ 83%]
   6:rpm-python             ########################################### [100%]
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-common-2.3.1-26.i386.rpm  
error: Failed dependencies:
        glibc-common = 2.3.1-25 is needed by (installed) glibc-2.3.1-25
[root@cognac 8.0.1]#


Comment 6 Nils Philippsen 2003-01-02 13:08:53 UTC
*** Bug 80914 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Johnson 2003-01-02 15:44:29 UTC
Fixed in rpm-4.2-0.49 afaik. Reopen if not, please.

Comment 8 Nils Philippsen 2003-01-02 16:34:26 UTC
works for me


Note You need to log in before you can comment on or make changes to this bug.