Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80911 - rpm crashes trying to upgrade to glibc-common-2.3.1-26 from 2.3.1-25
Summary: rpm crashes trying to upgrade to glibc-common-2.3.1-26 from 2.3.1-25
Keywords:
Status: CLOSED DUPLICATE of bug 80912
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 09:16 UTC by Nils Philippsen
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:51 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2003-01-02 09:18:33 UTC
Description of problem:

As the subject says, when I try to upgrade to glibc-common-2.3.1-26 (from -25),
rpm segfaults even before finishing dependency checks:

[root@cognac 8.0.1]# rpm -Fvh glibc/2.3.1-26/i686/glibc-2.3.1-26.i686.rpm \
glibc/2.3.1-26/i686/glibc-debuginfo-2.3.1-26.i686.rpm \
glibc/2.3.1-26/i686/nptl-devel-2.3.1-26.i686.rpm \
glibc/2.3.1-26/i386/glibc-common-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-debug-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-devel-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-profile-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/glibc-utils-2.3.1-26.i386.rpm \
glibc/2.3.1-26/i386/nscd-2.3.1-26.i386.rpm
Segmentation fault
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i686/glibc-2.3.1-26.i686.rpm
error: Failed dependencies:
        glibc-common = 2.3.1-26 is needed by glibc-2.3.1-26
        glibc = 2.3.1-25 is needed by (installed) glibc-debug-2.3.1-25
        glibc = 2.3.1-25 is needed by (installed) glibc-utils-2.3.1-25
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-common-2.3.1-26.i386.rpm
Segmentation fault
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-debug-2.3.1-26.i386.rpm
error: Failed dependencies:
        glibc = 2.3.1-26 is needed by glibc-debug-2.3.1-26
        glibc-devel = 2.3.1-26 is needed by glibc-debug-2.3.1-26
[root@cognac 8.0.1]# rpm -Uvh glibc/2.3.1-26/i386/glibc-devel-2.3.1-26.i386.rpm
error: Failed dependencies:
        glibc-devel = 2.3.1-25 is needed by (installed) glibc-debug-2.3.1-25

Version-Release number of selected component (if applicable):

rpm-4.2-0.48 (happened with -0.46 also)

How reproducible:

Always

Steps to Reproduce:
1. See above
    
Actual results:

rpm segfaults trying to install glibc-common-2.3.1-26

Expected results:

rpm installs packages or complains about unsatisfied dependencies

Comment 1 Nils Philippsen 2003-01-02 09:39:43 UTC
Accidentally duped.

*** This bug has been marked as a duplicate of 80912 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.