Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80893 - Setting MANWIDTH in environment does not successfully affect the displayed width of man pages.
Summary: Setting MANWIDTH in environment does not successfully affect the displayed wi...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-01 21:03 UTC by David Sumbler
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version: 1.5o1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-09 22:17:28 UTC


Attachments (Terms of Use)

Description David Sumbler 2003-01-01 21:03:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Man pages display 78 characters per line, even after I enter a command such as 

export MANWIDTH=100

The variable is being correctly set, but 'man' does not use this value, contrary
to what is stated in the 'man' manual.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter command 'export MANWIDTH=60' (for instance)
2. Enter command 'man ls' (for instance)

    

Actual Results:  Displayed width of man page is unaffected (78 characters).

Expected Results:  Width should have been 60 characters

Additional info:

Comment 1 Michael Wardle 2003-01-21 00:27:41 UTC
Seems to be related to bug 79172. 
 

Comment 2 Eido Inoue 2003-02-07 20:17:30 UTC

*** This bug has been marked as a duplicate of 79172 ***

Comment 3 Florian La Roche 2003-02-08 00:59:25 UTC
/ll is not setup from the current man, so this really looks like
a problem in man. Seems also it only allows setting the width in
a certain range, so I am not sure this is really a supported option.

greetings,

Florian La Roche


Comment 4 Eido Inoue 2004-11-09 22:17:28 UTC
man was not passing -rLT and -rLL to nroff/groff; fixed in current rawhide


Note You need to log in before you can comment on or make changes to this bug.