Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80876 - Application and Screen freezes in XFree86
Summary: Application and Screen freezes in XFree86
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 82788
TreeView+ depends on / blocked
 
Reported: 2003-01-01 17:17 UTC by Peter Scherer
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-12 15:28:23 UTC


Attachments (Terms of Use)
X server log (deleted)
2003-01-08 07:43 UTC, Peter Scherer
no flags Details

Description Peter Scherer 2003-01-01 17:17:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I recently installed RH 8.0 onto my computer.  Installation went fine. But when
I am in the GUI/XFree86 (either KDE or Gnome, it doesn't matterE) and I go to
use various applications the applications and main GUI screen will sometimes
freeze up.  Sometimes these are mouse freezes where the mouse will not work but
the keyboard commands will work.  Sometimes these are total freezes.  When I
press Ctrl-Alt-F4 it kicks me out of the GUI.  By pressing Ctrl-Alt-F7 it kicks
me back into the GUI and unfreezes the applications. But then I go to use it
again and usually within a few mouse clicks it freezes again. ONE EXCEPTION -
Mozilla is fairly stable and only freezes occasionally.  HELP! (I am a newbie so
be easy with all the new terminology)  NOTE that I had installed SUSE Linux 8.0
several months ago and I had the same problem.
Getting in and out of the problem in SUSE was handled by simply refreshing the
screen.  However I didn't like all the features of SUSE so I decided to switch
to Redhat.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enter a GUI environment, either KDE or GNOME.
2.Start using the keyboard or the mouse to enter applications.
3.Click or press keys a few times (sometimes a little longer) and the screen
will freeze or the mouse will freeze.
    

Actual Results:  The screen freezes or partially freezes or the application
window freezes.

Expected Results:  The GUI and applications should be responsive to the mouse
and keyboard commands.

Additional info:

I have a Celeron Mendicino 500 Mhz CPU on a DFI PA 61 motherboard (Slot 1 I
believe) witha VIA 693A chipset.  I had 64 mg RAM but after installing RH I
upgraded to 256 RAM (installed it myself) -- the bugs did not change at all but
the computer ran noticeably faster. It has a Stealth 3 Savage 4 video card and I
believe the audio is built into the motherboard (Yamaha chip) but I'm not
sure.My HD is 10 of 11 Gigabytes.

Comment 1 Mike A. Harris 2003-01-02 09:41:50 UTC
Configure your machine for runlevel 3, and then use startx to start up X.
Using the link below, attach the X server log, and config file individually
from after a crash after copying them safely so it is not overwritten by
starting up X again.



Comment 2 Peter Scherer 2003-01-08 07:43:42 UTC
Created attachment 89210 [details]
X server log

Comment 3 Mike A. Harris 2003-01-26 10:06:34 UTC
No config file attached....  waiting for config...

Comment 4 Mike A. Harris 2003-02-13 11:33:23 UTC
This bug report does not contain sufficient information to process.  I am
defering it to the upstream driver maintainer.  Please contact Tim Roberts
directly, or file a bug report to XFree86.org so that a developer whom has
both the hardware and the specifications, as well as direct familiarity with
your specific video chipset can investigate this issue and give it the
attention it may deserve.


Comment 5 Mike A. Harris 2003-03-12 15:28:23 UTC
There are no other users with the same hardware reporting the same problem.
Since it occurs under more than one Linux distribution also, I conclude
that you may have bad hardware or some hardware specific issue.  There is
insufficient information in the bug report to speculate further than that
however.


Note You need to log in before you can comment on or make changes to this bug.