Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80869 - executil.py:216:gtkExecWithCaptureStatus: TypeError: len() of unsized object
Summary: executil.py:216:gtkExecWithCaptureStatus: TypeError: len() of unsized object
Keywords:
Status: CLOSED DUPLICATE of bug 80355
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-01 12:52 UTC by Inger Karin Haarbye
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:50 UTC


Attachments (Terms of Use)

Description Inger Karin Haarbye 2003-01-01 12:52:17 UTC
Description of problem: 8.0.92 (Phoebe) 
I use redhat-config-network to add an isdn-connection and configure it, when trying to activate 
the connection I get a traceback. 
 
Version-Release number of selected component (if applicable): 
 
redhat-config-network-1.1.86-1 
 
How reproducible: 
 
tried twice. 
 
Steps to Reproduce: 
1. Configure isdn-card (Teles 16.3c PnP) with redhat-config-network 
2. Configure a connection to my ISP. 
3. Trying to activate connection 
     
Actual results:  
Traceback 
 
 
Expected results:  
ISDN-connection to my ISP  
  
 
 
Additional info:  
 
[inger@opuntia inger]$ cat neat-traceback.txt 
Component: redhat-config-network 
Version: 1.1.86 
Summary: TB 
/usr/lib/python2.2/site-packages/rhpl/executil.py:216:gtkExecWithCaptureStatus: TypeError: 
len() of unsized object 
 
Traceback (most recent call last): 
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py", line 734, in 
on_deviceActivateButton_clicked 
    (status, txt) = intf.activate(device) 
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line 107, in activate 
    return gtkExecWithCaptureStatus(command, [command, device]) 
  File "/usr/lib/python2.2/site-packages/rhpl/executil.py", line 216, in 
gtkExecWithCaptureStatus 
    if len(catchfd): 
TypeError: len() of unsized object 
 
Local variables in innermost frame: 
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'> 
catchfd: 1 
searchPath: 0 
read: 13 
stdin: 0 
argv: ['/usr/sbin/isdnup', 'isdn0'] 
write: 14 
command: /usr/sbin/isdnup 
closefd: -1 
root: / 
childpid: 0

Comment 1 Harald Hoyer 2003-01-08 17:00:28 UTC

*** This bug has been marked as a duplicate of 80355 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.