Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80860 - RFE: add ctrl-left/right bindings for xterm to /etc/inputrc
Summary: RFE: add ctrl-left/right bindings for xterm to /etc/inputrc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
: 111694 143040 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-01 09:52 UTC by Hans de Goede
Modified: 2014-03-17 02:33 UTC (History)
3 users (show)

Fixed In Version: 2.5.34-1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-23 05:34:28 UTC


Attachments (Terms of Use)

Description Hans de Goede 2003-01-01 09:52:53 UTC
since /etc/inputrc now contains bindings for ctrl-left / ctrl-right for
gnome-terminal, it would be nice ot add them for xterm too.

Lines for gnome-terminal (already there):
"\e[5C": forward-word
"\e[5D": backward-word

Lines to add for xterm:
"\e[1;5C": forward-word
"\e[1;5D": backward-word

Another option would be to standardify the termial behaviour for
ctrl-left/right, but since there's no standard for this just accepting both
probably is the best. Esp since other vendors will be shipping an unmodified xterm.

Comment 1 Hans de Goede 2004-07-21 15:41:05 UTC
ping?


Comment 2 Bill Nottingham 2004-09-23 05:33:25 UTC
*** Bug 111694 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2004-09-23 05:34:28 UTC
Added in 2.5.34-1.

Comment 4 Bill Nottingham 2004-12-16 14:44:44 UTC
*** Bug 143040 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.