Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80844 - redhat-config-packages broken in 8.0
Summary: redhat-config-packages broken in 8.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-31 23:04 UTC by Need Real Name
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-29 20:43:13 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-31 23:04:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The package manager is broken: it lists some installed packages as being not
installed; lists others as being installed that I'm pretty sure are not.  Then
when I activate the "update" button by selecting and then deselecting one
package, and click it, the package manager notifies that NN packages have been
selected for deletion and MM packages selected for installation -- even though
I've actually elected to make no changes!

Unfortunately, the last time I tested this, it notified me that it was about to
delete 32 components or packages, including gnome, the gimp, nautilus, metacity,
file-roller, the control center and more.

I have test this on all three of my RH 8.0 systems; the exact mistakes the
Package Installer makes in identifying packages to install and delete have been
different on each system; I have not made a record to compare whether the list
of installed packages turns out the same each time the package manager is broken.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Foot ->
2. System Settings ->
3. Packages ->
4. Passowrd for root ->
5. Look at the collected packages ->
6. Activate the "Update" button by selecting or deselecting something
7. Click "Update"
8. Look at the results!
    

Actual Results:  See Description

Expected Results:  Proper detection of installed and uninstalled packages

Additional info:

An unprepared person could trash their installation!

Comment 1 Jeremy Katz 2003-01-02 02:58:29 UTC
Could you give me the output of 'rpm -qa' on your system?

Comment 2 timm5 2003-03-20 01:17:35 UTC
dear mr katz
re:  redhat-config-packages 1.0.1-1
and how the prog sometimes tries remove things that weren't unchecked.
(or tries to install things that weren't checked)

reading through the 80 bugs w/this program,
i think there are alot of duplicates entries
pointing the this same/similar problem.

moreover, i think you've answered the problem with this address
http://people.redhat.com/~katzj/redhat-config-packages/1.0.2-1/
i upgraded from 1.0.1-1 to 1.0.2-1 with no problems.
and it seems to have done the fix!

i think what is happening here is other bugzilla users aren't finding the fix
that you've (once) supplied!..

(you're other versions require upgrades of 'rhpl' and/or 'rpm-python'
so i haven't bothered...)

timm5@usa.net


Note You need to log in before you can comment on or make changes to this bug.