Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80843 - "hdd=ide-scsi" not appended to /boot/grub/grub.conf kernel line
Summary: "hdd=ide-scsi" not appended to /boot/grub/grub.conf kernel line
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: grub
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-31 23:01 UTC by keith adamson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-01 08:42:19 UTC


Attachments (Terms of Use)

Description keith adamson 2002-12-31 23:01:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When installing RH, "hdd=ide-scsi" not appended to /boot/grub/grub.conf kernel
line when system has 2 ATAPI CD/DVD-ROM drives.  Same problem with RH 8.0

My system:
hdc: PLEXTOR CD-R PX-W1610A, ATAPI CD/DVD-ROM drive
hdd: Pioneer DVD-ROM ATAPIModel DVD-106S 011, ATAPI CD/DVD-ROM drive


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install 
2.  Boot
3.  Only one drive has ATAPI enabled
    

Actual Results:  Only one drive has ATAPI enabled

Expected Results:  Both drives should have ATAPI enabled

Additional info:

Comment 1 Jeremy Katz 2003-01-01 08:42:19 UTC
No, we only use ide-scsi for CD-Rs because it's needed to actually do CD
recording due to silliness in how cdrecord and the SCSI midlayer interact. 
Otherwise, ide-cd is just fine.

Comment 2 Marek Kassur 2003-01-01 19:46:27 UTC
But some programs require this functionality, rpcmgr is one of them for example.

http://perso.club-internet.fr/farzeno/dvds/rpcmgr11.c
(please read comments in header of this file)


Comment 3 Marc Deslauriers 2003-01-01 20:24:00 UTC
GToaster needs for the cd-rom reader to be ide-scsi also for it to be able to
copy from cd to cd. I think this would be a good idea.



Note You need to log in before you can comment on or make changes to this bug.