Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80819 - Kernel is not handling multiple tasks correctly (not sure its a task problem)
Summary: Kernel is not handling multiple tasks correctly (not sure its a task problem)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-31 17:58 UTC by Thiago Sayao
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:21 UTC


Attachments (Terms of Use)

Description Thiago Sayao 2002-12-31 17:58:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When i copy files from a cd-rom for example all the system gets slow
(maybe an ext3 problem ?). I ran the command top (several times) to see the cpu
utilization and the maximum was 20%. I copied the files with both nautilus and
the command cp and both gives me the same result, everything gets slow. By slow
i mean *very* slow.

My hardware:
 Athlon 1.2Ghz 256mb ram
 52x creative cd-rom
 Hd maxtor 40gb ata 133 (my board is ATA 100)
 Asus A7A133.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Copy files from a not-so-fast media to the root partition.
2. The system will be ***VERY*** slow during the copy.

    

Additional info:

Comment 1 Nathan G. Grennan 2002-12-31 19:52:20 UTC
Check to see if your cdrom is using DMA with hdparm -d device  RedHat has made
it policy to disable DMA on cdrom drives for compatiability reasons. Which has
the effect of greatly slowing it down for everyone else.

Comment 2 Thiago Sayao 2002-12-31 22:53:20 UTC
[root@zeus sayao]# /sbin/hdparm -d /dev/cdrom
 
/dev/cdrom:
 using_dma    =  1 (on)


Its enabled. 

Comment 3 Thiago Sayao 2003-01-05 00:34:34 UTC
During the boot kernel shows this message:
/dev/hda
DMA Disabled

my cd-rom is /dev/hda



Comment 4 Jim Shanks 2003-03-04 18:13:22 UTC
The only way that I have found to reliably switch CD-ROM drives to DMA Mode is to:

su to root
cd /etc/sysconfig
cp harddisks harddiskhda (or harddiskhdb or whatever your CD-ROM is.)

edit the newly created harddiskhda with a text editor and change the USE_DMA=0
to USE_DMA=1.

save the file and restart the machine.


Comment 5 Bugzilla owner 2004-09-30 15:40:21 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.