Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80800 - redhat-config-package gives error during package installation
Summary: redhat-config-package gives error during package installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-31 16:11 UTC by Pavel
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version: 1.1.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-22 04:25:08 UTC


Attachments (Terms of Use)

Description Pavel 2002-12-31 16:11:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021230

Description of problem:
When using redhat-config-packages to install new package(s), I get following
error dialog during installation:
"There was an
error installing packages. Exiting"
I also see on the message on the terminal saying:
"The
file /mnt/cdrom/RedHat/RPMS/<some package name> cannot be opened. This is
due to a missing file, a bad package or bad media. Press <return> to try
again". The package is in place and 'rpm -K /mnt/cdrom/RedHat/RPMS/<some package
name>' gives no errors.

Also when running redhat-install-packages <some package> following traceback is
printed:
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/SinglePackageWindow.py", line 238,
in ?
    main_window.run()
  File "/usr/share/redhat-config-packages/SinglePackageWindow.py", line 201,
in run
    self.do_package_check ()
  File "/usr/share/redhat-config-packages/SinglePackageWindow.py", line 79,
in do_package_check
    if isSource:
NameError: global name 'isSource' is not defined 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-packages and try to install some packages
2. Run redhat-install-packages to install some package
3.
    

Actual Results:  Errors using tools

Expected Results:  To be able to install the packages either way.

Additional info:

I'm using new redhat-config-packages-1.1.1-1 and new pygtk2

Comment 1 Jeremy Katz 2003-01-02 03:46:59 UTC
Fixed in 1.1.2, going up to
http://people.redhat.com/~katzj/redhat-config-packages/1.1.2/ as soon as it
finishes building

Comment 2 John Thacker 2006-04-22 04:25:08 UTC
Long fixed, RH 9 not supported except in Fedora Legacy, and s-c-p isn't 
shipped anymore.  (Pirut replaced s-c-p.)  Closing.




Note You need to log in before you can comment on or make changes to this bug.