Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8079 - Strange recursive delete bug in latest samba RPM
Summary: Strange recursive delete bug in latest samba RPM
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-31 01:52 UTC by gbowland
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-17 08:31:00 UTC


Attachments (Terms of Use)

Description gbowland 1999-12-31 01:52:18 UTC
Hi,

I'm working for a company that has many users using samba and Red Hat
Linux 6.1. We've found a problem that we can reproduce using the latest
samba release (2.0.6). It is fairly hard to describe accurately but I will
do my best.

All of the users involved are in the group 'ihgtech'. The problem
involves recursive deletion of directories owned by another user
and the group 'ihgtech'.

Consider a directory 'source' with two sub-directories, 'a' and 'b'.
We have found that, even though all of the files and directories
below and including 'source' have write permission set for members
of 'ihgtech', 'rm -rf source/' fails with permission denied errors
for the sub-directories.

If we do a verbose rm, `rm -rfv' we see that rm believes it has deleted
files that are still there after the command has finished. Because these
files are left behind rm receives a permission denied error when attempting
to remove the directory containing the files.

We find the bug behaves in the same way each time, although we do not
understand the behaviour. I will attempt to illustrate below:

caltest2/ -- inc/ -- (files)
          -- src/ -- last -- (files)
                  -- (files)
          -- tmp/ -- (files)
          -- (files)

Then, after `rm -rf caltest2':

caltest2/ -- inc/ -- (files removed, directory remains)
          -- src/ -- last/ -- (files removed)
          -- src/ -- (files)

Execute above command again:

caltest2/ -- src/ -- last/ -- (files removed)
          -- src/ -- (less files than before)

And again:

-- ALL FILES GONE --

Thanks for any help you can provide. Some system details follow:

$ uname -a
Linux bertie.ihgtech.com.au 2.2.5-15 #1 Mon Apr 19 23:00:46 EDT 1999 i686
unknown

$ cat /etc/samba.conf
# Samba config file created using SWAT
# from sysadmin.ihgtech (192.168.0.2)
# Date: 1999/11/26 09:29:23

# Global parameters
	workgroup = IHGTECH
	netbios name = BERTIE
	server string = Samba Server
	password level = 4
	log file = /var/log/samba/log.%m
	max log size = 50
	socket options = TCP_NODELAY
	printcap name = /etc/printcap
	logon script = logon.bat
	logon path = \\%N\%U\.profile
	domain logons = Yes
	preferred master = Yes
	domain master = Yes
	dns proxy = No
	wins support = Yes
	guest account =
	hosts allow = 192.168.0. 127. 192.168.3.

[homes]
	comment = %u's Home Directory
	read only = No
	create mask = 0640
	directory mask = 0750
	browseable = No

[printers]
	comment = All Printers
	path = /var/spool/samba
	print ok = Yes
	browseable = No

[netlogon]
	comment = Windows Net Logon Directory
	path = /home/files/netlogon
	browseable = No

[profile]
	comment = Windows user profiles
	path = /home/files/profile
	read only = No
	create mask = 0600
	directory mask = 0700
	browseable = No

[trash]
	comment = Trash Area
	path = /home/files/trash
	force group = users
	read only = No
	create mask = 0660
	directory mask = 0770

[arrow]
	comment = The Arrow Area
	path = /home/files/arrow
	admin users = nrar
	force group = arrow
	read only = No
	create mask = 0660
	directory mask = 0770

[engineering]
	comment = IHG Technologies Engineering Filespace
	path = /home/files/engineering
	valid users = +ihgtech, rjr
	admin users = nrar, bmt
	read list = rjr
	force group = ihgtech
	read only = No
	create mask = 0660
	directory mask = 0770

[homedir]
	path = /home
	valid users = nrar, bmt
	admin users = nrar, bmt
	read only = No
	browseable = No

[anz]
	comment = ANZ Online Files
	path = /home/files/anz
	valid users = +anz
	admin users = nrar
	force group = anz
	read only = No
	create mask = 0660
	directory mask = 0770
	browseable = No

[admin]
	comment = Administrative File Area
	path = /home/files/admin/
	valid users = +users
	admin users = nrar
	force group = users
	create mask = 0660
	directory mask = 0770

[hwintraweb]
	comment = Hardware Intraweb
	path = /home/httpd/html/hwintraweb
	write list = am, az, nrar
	force group = hwintraweb
	read only = No
	create mask = 0664
	directory mask = 0775
	browseable = No

Comment 1 gbowland 2000-01-17 02:49:59 UTC
I've talked to the Samba people, this is a Linux kernel issue with mounting
smbfs.


Note You need to log in before you can comment on or make changes to this bug.