Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80784 - In SMB printer configuration, password escape character ends up in the password string
Summary: In SMB printer configuration, password escape character ends up in the passwo...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 87748 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-31 10:03 UTC by Ari Inki
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-27 14:54:21 UTC


Attachments (Terms of Use)

Description Ari Inki 2002-12-31 10:03:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Try to configure a SMB printer to use via the redhat-config-printer-gui. If the
SMB password contains a character which usually is escaped, the escape character
ends up in the password string. To verify enable smbprint.log in
/usr/share/printconf/util/smbprint

84c84
< #echo $share $password $translate $x_command > /tmp/smbprint.log
---
> echo $share $password $translate $x_command > /tmp/smbprint.log

and see what ends up in the smbprint.log


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. SMB password with e.g. '!' character
2. Try to use a SMB printer with the account which has '!' in the pwd
3. '!' is incorrectly escaped, with the escape character in the pwd
    

Actual Results:  Failure to perform requested operation & account lockout.

Expected Results:  Ability to perform requested operation.

Additional info:

Comment 1 Miloslav Trmac 2002-12-31 18:14:18 UTC
Plus the variables should be referenced as "$share",
to avoid share='x`rm -rf /usr`y' surprises (generally,
any shell metacharacters).

Comment 2 Miloslav Trmac 2002-12-31 18:15:28 UTC
Oops, make that
x='a b'
surprises.


Comment 3 Tim Waugh 2003-01-17 14:19:39 UTC
Using LPRng, right?

Comment 4 Ari Inki 2003-01-17 15:23:56 UTC
Right. Using LPRng.

Comment 5 Tim Waugh 2003-01-27 14:54:21 UTC
'!' was being mistakenly escaped.  Other characters need escaping though.

Fixed package is redhat-config-printer-0.6.41-1.

Comment 6 Tim Waugh 2003-04-02 11:11:42 UTC
*** Bug 87748 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.