Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80780 - Window focus doesm't return to mozilla window
Summary: Window focus doesm't return to mozilla window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kinput2
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Depends On:
Blocks: 82816
TreeView+ depends on / blocked
 
Reported: 2002-12-31 09:43 UTC by Takanori MATSUURA
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-18 06:59:17 UTC


Attachments (Terms of Use)

Description Takanori MATSUURA 2002-12-31 09:43:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20021229

Description of problem:
Window focus doesn't return to mozilla window after converting kana charactor to
kanji charactor.

It occurs when using mozilla-1.1 or later on RedHat Linux 8.0.

According to http://bugzilla.mozilla.org/show_bug.cgi?id=63456
this is the bug of kinput2-v3.

In my test, this bug is fixed by using kinput2-v3.1 and latest metacity.

See also (Mozilla-gumi, Written in Japanese.)
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2810
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2819

How reproducible:
Always

Actual Results:  Window focus doesn't return to mozilla window.

Expected Results:  Window focus should be returned to mozilla window.

Additional info:

kinput2-v3.1 is available from
ftp://ftp.sra.co.jp/pub/x11/kinput2/kinput2-v3.1.tar.gz

Comment 1 Nakai 2003-01-30 11:37:14 UTC
It seems to work on Phoebe beta4 + Mozilla 1.2.1-15

Comment 2 Leon Ho 2003-02-07 06:23:15 UTC
Jens also cannot reproduce with rawhide packages now. Please check and reopen 
if it still shows. 

Comment 3 Akira TAGOH 2003-04-18 06:59:17 UTC
older metacity had a focus issue. this problem should be fixed in current release.


Note You need to log in before you can comment on or make changes to this bug.