Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80763 - possibly broken source code
Summary: possibly broken source code
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mtools
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-30 23:48 UTC by d.binderman
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-10 17:04:05 UTC


Attachments (Terms of Use)

Description d.binderman 2002-12-30 23:48:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I have just tried to compile mtools-3.9.8-5 from Redhat 8.0

Here are some of the messages the compiler produces

cc: Info: mformat.c, line 976: In this statement, an array is being accessed outside the bounds specified for the array type. (subscrbounds)

The code in question seems to be

	set_word(boot->jump + 510, 0xaa55);

It's a mystery to me what's going on here. Maybe you can make more progress
with this than I can.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with any C compiler which checks array indices, such as Compaq C.
2.
3.
    

Additional info:

Comment 1 Tim Waugh 2004-12-10 17:04:05 UTC
I'm not going to mess about with this, since it seems to be "magic" and doesn't
cause any ill effects that I have seen.


Note You need to log in before you can comment on or make changes to this bug.