Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80751 - Messages from rpm upgrades spew on tty and do not get logged
Summary: Messages from rpm upgrades spew on tty and do not get logged
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
: 81118 82272 (view as bug list)
Depends On: 80774
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-30 21:53 UTC by Glen A. Foster
Modified: 2007-04-18 16:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-30 18:25:58 UTC


Attachments (Terms of Use)

Description Glen A. Foster 2002-12-30 21:53:39 UTC
Description of problem: During an upgrade from RHL 8.0 to Phoebe, I am seeing 
messages from rpm being spewed in red-highlighted text "boxes" against the 
normal blue TUI-mode screen background.  The message currently displayed is:

warning: /usr/share/info/dir created as /usr/share/info/dir.rpmnew

Version-Release number of selected component (if applicable):
Phoebe

How reproducible: 100% (always)

Steps to Reproduce:
1. Everything install of RHL 8.0
2. Upgrade existing 8.0 install to Phoebe using TUI

Comment 1 Jeremy Katz 2002-12-31 04:53:29 UTC
Known problem due to changes down in rpm land

Comment 2 Glen A. Foster 2002-12-31 17:10:33 UTC
This is even more apparent in a 7.3 -> Pheobe upgrade.

Comment 3 Jeremy Katz 2003-01-06 18:05:39 UTC
*** Bug 81118 has been marked as a duplicate of this bug. ***

Comment 4 Aleksey Nogin 2003-01-06 21:43:51 UTC
This also happens with graphics install - the rpm messages go to tty1 instead of
going to upgrade.log (as they used to). This is IMHO a high severity problem
since important messages (such as messages about rpmnew/rpmsave of configs being
created) can get lost.

Comment 5 Jeremy Katz 2003-01-23 00:55:50 UTC
*** Bug 82272 has been marked as a duplicate of this bug. ***

Comment 6 Need Real Name 2003-01-28 15:28:54 UTC
I wonder if this is also my problem. When installing RPMs with Nautilus, if
prblems are found, such as pre-reqs, the RPM dialog exits without noting what is
wrong. Running from the command line will disclose the problem. 

Comment 7 Jeremy Katz 2003-01-29 04:21:23 UTC
Using the new rpm functionality for this in CVS

Comment 8 Jeremy Katz 2003-01-29 21:36:35 UTC
*** Bug 83042 has been marked as a duplicate of this bug. ***

Comment 9 Mike McLean 2003-01-30 18:25:20 UTC
fix verified


Note You need to log in before you can comment on or make changes to this bug.