Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80749 - Some icons under gnome menu looks fuzzy
Summary: Some icons under gnome menu looks fuzzy
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-artwork
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-12-30 20:59 UTC by louisgtwo
Modified: 2007-04-18 16:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-06 07:48:18 UTC


Attachments (Terms of Use)

Description louisgtwo 2002-12-30 20:59:31 UTC
icons for Log Out and Lock Screen looks very fuzzy, expecially if you drag them
onto the panel. Many more icons on the gnome menu look fuzzy to.

Comment 1 Bill Nottingham 2003-01-01 06:18:46 UTC

*** This bug has been marked as a duplicate of 80366 ***

Comment 2 louisgtwo 2003-01-01 19:05:32 UTC
Bug 80366 has nothing to do with this bug. I don't get it.

Comment 3 Havoc Pennington 2003-01-13 04:48:45 UTC
I'm pretty sure the bug is a dup, Bill must have just typed the wrong number.

Alex - Kenneth thought the icons from the icon theme were fuzzy 
and /usr/share/pixmaps icons were not. I didn't verify. Maybe we are picking 
the wrong sizes?

Comment 4 Alexander Larsson 2003-01-14 14:25:44 UTC
There are two problems
a) GnomeIconTheme picked 16x16 instead of 32x32 when looking up a 20x20 icon.
I've checked in a fix to libgnomeui HEAD that makes it never scale up unless it
has to.

b) we still have prescaled icons in the Bluecurve theme, and the
X-GNOME-AlreadyScaled=true hack doesn't work anymore.

Comment 5 Kenneth Rohde Christiansen 2003-01-14 14:40:12 UTC
I installed cvs libgnomeui and removed the X-GNOME-AlreadyScaled=true lines from
Bluecurve/index.theme - now everything works. Thanks Alex!

Comment 6 Havoc Pennington 2003-01-15 00:33:55 UTC
It's not as bad now but Garrett thinks we are still e.g. scaling the menu icons
from 32x32 instead of 48x48.

IMO we should:
 - put back the Makefile stuff to do scaling
 - remove any scaled icons that are checked in to CVS
 - restore the X-GNOME-AlreadyScaled hack, or do the automated 
   Makefile scaling to all sizes we use.

Comment 7 Alexander Larsson 2003-01-15 09:34:25 UTC
Why do you think we need the prescaled icons? What requires them?


Comment 8 Alexander Larsson 2003-01-15 09:38:57 UTC
Btw. Yes, we do currently scale down the 32x32 icon.


Comment 9 Havoc Pennington 2003-01-15 14:21:20 UTC
KDE required the scaled icons in 8.0. It may no longer require them, then 
we can just kill them, but so far no one has *verified* that KDE no longer 
requires them.

Comment 10 Havoc Pennington 2003-01-15 14:26:02 UTC
Let's do this:
 - remove the prescaled icons from CVS
 - I'll test KDE for breakage
 - we can add the autoscaler if required


Comment 11 Alexander Larsson 2003-01-15 18:11:27 UTC
Good plan. In fact I'm already working on the patch to fix KDE scaling (which
seems to be existing, but buggy).


Comment 12 Garrett LeSage 2003-07-31 16:35:46 UTC
Multiple sizes of the icons are now provided. I checked in the sheets and
changed the config file for the app icons yesterday. For stock icons (which are
not in KDE, yet), there are already a few sizes as well. I plan on implementing
more sizes for the filesystem and mimetype icons soon.


Note You need to log in before you can comment on or make changes to this bug.