Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80737 - FTP install Fails before package selection screen
Summary: FTP install Fails before package selection screen
Keywords:
Status: CLOSED DUPLICATE of bug 80676
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-30 17:43 UTC by Chris Ford
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:47 UTC


Attachments (Terms of Use)
This is the anacando dump from the install. (deleted)
2002-12-30 17:44 UTC, Chris Ford
no flags Details

Description Chris Ford 2002-12-30 17:43:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021204

Description of problem:
I have tried to install via FTP from my FTP server on my local LAN.  I used the
same method that I have used on every release in the past.  My workstation is an
AMD Athlon 1.2 GHz on an Abit KT7A motherboard.    I copied all of disk 1 to a
FTP accessible folder and the RPMS from disk 2 and disk 3 into the RPMS folder.
 I then boot my worksation from disk 1 and run linux askmethod at the prompt.  I
am able to start the install and partition my HDD and set the locale etc.  I
then set the root password and it crashes with the following.  I have the
complete anaconda dump if it would be helpful.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 770, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/183995-i386/install//usr/lib/anaconda/text.py", line 446,
in run
  File "/usr/src/build/183995-i386/install//usr/lib/anaconda/dispatch.py", line
155, in gotoNext
  File "/usr/src/build/183995-i386/install//usr/lib/anaconda/dispatch.py", line
222, in moveStep
  File "/usr/src/build/183995-i386/install//usr/lib/anaconda/packages.py", line
125, in readPackages
  File "/usr/src/build/183995-i386/install//usr/lib/anaconda/urlinstall.py", line
123, in readHeaders
AttributeError: URLError instance has no attribute 'args'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot Phoebe disk 1 
2.linux askmethod and choose FTP install
3.Go through all steps up until setting root password.
4.Crash
    

Actual Results:  The install crashed with the above error.

Expected Results:  Should have progressed to the package selection screen.

Additional info:

I was able to install using all three CD's locally, and all three CD's did pass
the media check.

Comment 1 Chris Ford 2002-12-30 17:44:29 UTC
Created attachment 88990 [details]
This is the anacando dump from the install.

Comment 2 Bill Nottingham 2003-01-01 06:17:20 UTC

*** This bug has been marked as a duplicate of 80676 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.