Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80723 - Grub doesn't install on all disks of a software raid device automatically
Summary: Grub doesn't install on all disks of a software raid device automatically
Keywords:
Status: CLOSED DUPLICATE of bug 55484
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub
Version: 7.3
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-30 15:01 UTC by Hansjoerg Maurer
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:47 UTC


Attachments (Terms of Use)

Description Hansjoerg Maurer 2002-12-30 15:01:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.4.1) Gecko/20020518
Netscape6/6.2.3

Description of problem:
After installing /boot and / on a software Raid1 device, I recognized, that grub
is only installed on one of the disks of the raid array.
I one disk fails, the system won't boot any more

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install /boot and / on a software raid1 system (2 disks)
2.halt system and plug out one disk
3.try to reboot
    

Actual Results:  system doesn't boot any more

Expected Results:  system should boot from second disk

Additional info:

It is possible to install it manually on both disks by entering the following
commands (in my case).
But grub should do this automatically or ther should be a note, that the
bootloades is only installed on one disk.
Otherwise the redundancy of a raid 1 system is not reached

grub
device (hd0) /dev/hda
root (hd0,1)
install /grub/stage1 <*> (hd0) /grub/e2fs_stage1_5 /grub/stage2 /grub/grub.conf
device (hd0) /dev/hdb
root (hd0,1)
install /grub/stage1 <*> (hd0) /grub/e2fs_stage1_5 /grub/stage2 /grub/grub.conf

Comment 1 Jeremy Katz 2002-12-30 18:24:51 UTC

*** This bug has been marked as a duplicate of 55484 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.