Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80712 - neat many different crashes after incorrect set-up
Summary: neat many different crashes after incorrect set-up
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network
Version: phoebe
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578 81720
TreeView+ depends on / blocked
 
Reported: 2002-12-30 11:46 UTC by Paul Jenner
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 20:12:09 UTC


Attachments (Terms of Use)

Description Paul Jenner 2002-12-30 11:46:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
I launched neat to set-up my network devices - airo on eth1, static IP on boot
and 3c503 on eth0, not configured.

I added both hardware devices in the order above and then added a network
profile for the airo. At this point things went wrong and neat started to crash.

I believe all the following crashes are due to me configuring eth1 before eth0.
Although I specified eth1 for the first device and this got set-up correctly in
modules.conf, the kernel loaded the driver and assigned the device eth0 (since
it was the first ethernet device seen). Since I have no network config for eth0,
when the network scripts set-up what they think is eth1 on boot, the kernel
again loads the first network driver it sees and assigns it eth0.

Crash outputs follow:

1) initial crash (I think when removing eth0 device to try to fix the issue above):

Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py:1386:on_hardwareDeleteButton_clicked:
IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 539, in on_deleteButton_clicked
    self.deleteButtonFunc[self.active_page](button)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 1386, in on_hardwareDeleteButton_clicked
    page = clist.selection[0])
IndexError: list index out of range

Local variables in innermost frame:
buttons: -8
clist: <gtk.CList object (GtkCList) at 0x85cd0fc>
description: 3Com EtherLink II
type: Ethernet
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x854bad4>
args: (<gtk.Button object (GtkButton) at 0x85c8cf4>,)
hardwarelist: []
hw: <netconfpkg.NCHWEthernet.HwEthernet instance at 0x866989c>
dev: eth1

2) subsequent crash (I believe when activating eth1 after removal of eth0 above
failed):

Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/lib/python2.2/site-packages/rhpl/executil.py:216:gtkExecWithCaptureStatus:
TypeError: len() of unsized object

Traceback (most recent call last):
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 734, in on_deviceActivateButton_clicked
    (status, txt) = intf.activate(device)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
107, in activate
    return gtkExecWithCaptureStatus(command, [command, device])
  File "/usr/lib/python2.2/site-packages/rhpl/executil.py", line 216, in
gtkExecWithCaptureStatus
    if len(catchfd):
TypeError: len() of unsized object

Local variables in innermost frame:
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
catchfd: 1
searchPath: 0
read: 13
stdin: 0
argv: ['/sbin/ifup', 'eth1']
write: 14
command: /sbin/ifup
closefd: -1
root: /
childpid: 0

3) repeated crash every time neat is invoked now - before GUI appears:

Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/sbin/../share/redhat-config-network/netconfpkg/NCDevWireless.py:32:load:
NameError: global name 'ConfDevice' is not defined

Traceback (most recent call last):
  File "/usr/sbin/neat", line 98, in ?
    window = mainDialog()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 154, in __init__
    self.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 226, in load
    self.loadDevices()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 233, in loadDevices
    devicelist = getDeviceList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 163, in getDeviceList
    DVList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 70, in load
    newdev.load(dev)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDevWireless.py",
line 32, in load
    conf = ConfDevice(name)
NameError: global name 'ConfDevice' is not defined

Local variables in innermost frame:
self: <netconfpkg.NCDevWireless.DevWireless instance at 0x827e3b4>
name: eth1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I cannot reproduce the initial behaviour as I can no longer start neat successfully.

The latest crash is easily reproducable though:

1. run "neat" as root

Additional info:

Opened as high since neat is now unusable.

Comment 1 Paul Jenner 2002-12-30 11:51:11 UTC
My apologies for missing this initially - crash 2 is a dup of bug 80355.

Crash 1 and the reproducible crash 3 are still unique to this bug report though.

Comment 2 Harald Hoyer 2003-01-08 16:59:19 UTC
1) cannot reproduce.. I will try again later 
2) and 3) will be fixed with version >= 1.1.87

Comment 3 Paul Jenner 2003-01-11 12:28:58 UTC
I will await version 1.1.87, re-install phoebe and see if I can reproduce 1 on a
clean system.

Comment 4 Harald Hoyer 2003-01-13 15:18:08 UTC
new packages to test available at:
ftp://people.redhat.com/harald/redhat-config-network/1.1.87-1/
ftp://people.redhat.com/harald/rhpl/0.74-2/

Comment 5 Paul Jenner 2003-01-13 19:29:29 UTC
With test packages, neat now crashes on startup with:

Component: redhat-config-network
Version: 1.1.87
Summary: TB
/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareFactory.py:41:getHardwareClass:NameError:
global name 's' is not defined
Traceback (most recent call last):
  File "/usr/sbin/neat", line 155, in ?
    window = mainDialog()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 155, in __init__
    self.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 225, in load
    self.loadHardware()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 236, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 389, in getHardwareList
    HWList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 202, in load
    i = self.addHardware(type)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 134, in addHardware
    hwc = hwf.getHardwareClass(type)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareFactory.py", line
41, in getHardwareClass
    print "Error: %s not in HardwareFactory!" %s
NameError: global name 's' is not defined

Comment 6 Paul Jenner 2003-02-20 20:12:09 UTC
Works without problem under Phoebe beta 3 (redhat-config-network-tui-1.1.97-1).

For reference, as before:

* installed
* ran neat
* configured airo as eth1 static
* configured 3c503 as eth0 DHCP but not at boot
* tried to activate eth1 and it complained that eth1 was not available (the
module was loaded as eth0)
* rebooted and all worked


Note You need to log in before you can comment on or make changes to this bug.