Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 807 - duplicates and e-mails
Summary: duplicates and e-mails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 2.1rC
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-13 00:12 UTC by Aleksey Nogin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-19 13:34:02 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 1999-01-13 00:12:38 UTC
When a bug is marked as a duplicate, the Description field
is copied, but the e-mails are not, which is kind of
confusing.

Also, when there are several comments in the Description
field and couple of e-mails, I have to go back and forth if
I want to read everything in order it was posted (and, even
worse, the order is not clear until I look at all the e-mail
headers).

I would like to suggest a change that would solve both
problems: when a new e-mail arrives, the Bugzilla should
create a new entry in the Description field containing the
usual comment header:

------- Additional Comments From <e-mail sender> <e-mail
arrival date> -------

and a _link_ to e-mail (not to the e-mail directory, but to
the e-mail itself).

Comment 1 Need Real Name 1999-01-18 14:13:59 UTC
OK, some new code is in to update the ticket and send out a message
when email comes in on an open bug.  A link to the bug cannot be made
inside the description field, because it can only be plain text (think
C headers pasted as an example and it will become clear why).

The duplicate issue is fixed in CVS, and will be put into production
shortly.

Comment 2 Aleksey Nogin 1999-01-19 08:12:59 UTC
There is another issue with duplicates that was recently raised by
sczjd@yahoo.com in bug report #848 - when report #x is marked as a
duplicate of #y, the reporter of #x and all the people in the CC list
of #x should be added to the CC list of #y.

Comment 3 Need Real Name 1999-01-19 13:34:59 UTC
Right, the duplicate code was also updated to copy the owner and cc
list from the bug closed as a duplicate (#x) to the bug that is still
open (#y).


Note You need to log in before you can comment on or make changes to this bug.