Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80699 - mozilla saves maximized size (should not save size when in maximized state, or something)
Summary: mozilla saves maximized size (should not save size when in maximized state, o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
: 80619 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-30 02:14 UTC by Elton Woo
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-03 18:33:19 UTC


Attachments (Terms of Use)

Description Elton Woo 2002-12-30 02:14:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
see also Bug. 80619.
 If a window is opened, maximized, then closed _while maximized_, it does not
revert to it's original (un-maximized) size when re-opened). This problem is /  has
also been present in RH 8.0 (Psyche)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open any application in Gnome / metacity
2.Maximize the window, then close it.
3. Open any Gnome / metacity window
4. Click on "un/maximize' button
    

Actual Results:  Window retains it's maximized aspect.

Expected Results:  Window should revert to pristine (unmaximized) size.

Additional info:

see also Bug. 80619. Initially, I thought this was a mozilla problem. Please
fix, this
problem is still existant in Psyche (RH 8.0), even with the latest updates from
up2date. 

My video subsystem:
Viewsonic 17 , set to 1024 x 768 24-bit resolution.
Video card: JATON 3DForce B-32 Plus AGP (nVidia chipset), 32 Mb

Comment 1 Christopher Blizzard 2002-12-30 04:41:59 UTC
*** Bug 80619 has been marked as a duplicate of this bug. ***

Comment 2 Havoc Pennington 2003-01-02 16:06:43 UTC
Well, it *is* a mozilla problem. ;-)

Mozilla saves the window size, without paying attention to the maximization state. 
Not metacity's fault. Moz has access to the maximization state if it wants to
use it.

Comment 3 Elton Woo 2003-01-11 20:44:26 UTC
I've updated nautilus, etc from rawhide (latest packages to Jan 10), but the
problem still
exists.

Comment 4 Warren Togami 2003-01-21 08:00:53 UTC
Still exists in Phoebe2.


Comment 5 Elton Woo 2003-01-24 18:56:35 UTC
I was hoping that this would be fixed by now, but it still persits in Phoebe2

Comment 6 Elton Woo 2003-02-26 05:21:52 UTC
Also still present in "original" Phoebe 3 (RH 8.0.94). I have not looked in
rawhide yet for any possible fixes.

Comment 7 Elton Woo 2003-03-12 21:37:32 UTC
I have created a jpeg attachment to Bug#85819 which seems to be related to *this*
bug.

Comment 8 Elton Woo 2003-11-02 20:55:30 UTC
This appears to have been fixed in Fedora Core. I respectfully submit
that this should be closed.

Comment 9 Christopher Blizzard 2003-11-03 18:33:19 UTC
Done.


Note You need to log in before you can comment on or make changes to this bug.