Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80691 - Faulty Backspace and Delete key mapping
Summary: Faulty Backspace and Delete key mapping
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-29 23:52 UTC by jw1233219
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-02 20:04:46 UTC


Attachments (Terms of Use)

Description jw1233219 2002-12-29 23:52:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; hahaha-fooled you!
This is really Mozilla/5.0 on Linux i686 rv:1.0.1 Gecko/2002103)

Description of problem:
On the US keyboard mapping the key Backspace is mapped to keysym=Delete and the
key Delete is mapped to keysym=Remove.

Shouldn't Backspace map to Backspace and Delete to Delete?

Other packages have been munged to make this strange mapping work.
    ncurses - terminfo.src has xterm-redhat instead of xterm-xfree86
              just because of strange backspace/delete mapping.
              It also has munged backspace definition for the linux
              definition.

            

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. loadkeys us
2. dumpkeys | egrep ' 14| 111'
3.
    

Actual Results:  keycode  14 = Delete
keycode 111 = Remove


Expected Results:  keycode  14 = Backspace
keycode 111 = Delete


Additional info:

With a corrected keymap, corrected terminfo, everything works properly,
including X/xterm.

Even the kernel refers to keycode 111 as Delete, and keycode 14 as Backspace
(keyboard.c,pc_keyb.c).

Why should the keyboard mappings create an inconsistency?

Comment 1 Eido Inoue 2003-01-02 20:04:46 UTC
This is by design. A lot of users expect the functionality of "Delete" when they
press "Backspace". Try reversing the two and running a lot of apps.

I'm unable to understand what you mean by X/xterm working when you re-map the
two. The current mappings seem to WORKFORME.


Note You need to log in before you can comment on or make changes to this bug.