Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80690 - kernel hangs after logout: Radeon card with DRM enabled
Summary: kernel hangs after logout: Radeon card with DRM enabled
Keywords:
Status: CLOSED DUPLICATE of bug 79678
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-29 23:18 UTC by ctm
Modified: 2008-01-17 17:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:46 UTC


Attachments (Terms of Use)
X configuration file (deleted)
2003-01-02 15:59 UTC, ctm
no flags Details
log file for XFree86 run when system hung (deleted)
2003-01-02 16:00 UTC, ctm
no flags Details
/var/log/messages starting from the boot of the RH kernel that froze (deleted)
2003-01-02 16:01 UTC, ctm
no flags Details

Description ctm 2002-12-29 23:18:58 UTC
Description of problem:

I intalled Phoebe on a GRX 600 series VAIO laptop that was running RH 8.0
nicely.  If I leave DRM (load "dri") enabled, when I log out the machine will
lock solid.

Version-Release number of selected component (if applicable):

XFree86-4.2.99.2-0.20021217.0
kernel-2.4.20-2.2

How reproducible:

100%, although sometimes I need to log in and log out more than once for it to
happen (not usually).

Steps to Reproduce:
1. using default XFree86 config with 'Load "dri"' in place, log in
2. log out
3.
    
Actual results:
Machine hangs

Expected results:
login screen should come back

Additional info:

If I comment the 'Load "dri"' line out, the hang doesn't happen.

I get the same behavior when I use the stock Phoebe kernel and when I use
one I built myself (that has a different ACPI patch).

I actually upgraded to a manually recompiled XFree86-4.2.99.2-0 XFree86 (from
rawhide) shortly before Phoebe came out (I would have waited for Phoebe, had I
known it was coming out), and that's when I first started seeing this hang. 
However, when I upgraded to Phoebe I double-checked to make sure I get the
official Red Hat compiled binaries (so you won't be chasing a Red Herring). 
Before I upgraded to the rawhide release I was running the stock Red Hat 8.0
XFree86 version and was using DRM and not seeing the hang.

Comment 1 ctm 2002-12-29 23:48:10 UTC
The chip as described by /proc/pci is:
 Bus  1, device   0, function  0:
    VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW (rev 0).
      IRQ 9.
      Master Capable.  Latency=66.  Min Gnt=8.
      Prefetchable 32 bit memory at 0xf0000000 [0xf7ffffff].
      I/O at 0x3000 [0x30ff].
      Non-prefetchable 32 bit memory at 0xe8100000 [0xe810ffff].

and by XFRee86 it's:

(--) Chipset ATI Radeon Mobility M7 LW (AGP) found



p.s. I see the XFree86 4.2.99.3 README explicitly say that the radeon driver
will be worked on between now and the release of XFree86 4.3.0, but I don't see
any acknowledgment of actual kernel hangs or any other explanation of what the
XFree86 people already know is bad about the radeon driver.



Comment 2 Mike A. Harris 2003-01-02 08:14:35 UTC
Please attach X log, X config, and messages log as individual file
attachments using the link below.

Comment 3 Gerry Tool 2003-01-02 14:59:42 UTC
This also happens to me with a stock new install on an Athlon XP1800+, Radeon
7500 graphics card desktop machine.  I have to hit the reset button after every
logout.  I have not explicitly set any parameters for my video card; they are
whatever the default install provides.

Comment 4 ctm 2003-01-02 15:59:35 UTC
Created attachment 89054 [details]
X configuration file

The temporary hack comment was left there from when I had commented out
the Load "dri" line.  The comment doesn't make sense since Load "dri" isn't
commented out.

Comment 5 ctm 2003-01-02 16:00:22 UTC
Created attachment 89055 [details]
log file for XFree86 run when system hung

Comment 6 ctm 2003-01-02 16:01:18 UTC
Created attachment 89056 [details]
/var/log/messages starting from the boot of the RH kernel that froze

Comment 7 ctm 2003-01-02 16:05:55 UTC
I haven't done it enough times to be statistically significant, but twice when I
was trying to get the log file, I booted, logged in, started a terminal, typed
"sync", waited for the disk activity light to finish, logged out and the system
did not freeze.  Instead I was able to log in again.  Then I logged out
immediately and the system froze.  So there's a chance that disk activity
contributes to the lock up.  It may also have just been coincidence.

Comment 8 Mike A. Harris 2003-01-15 07:50:09 UTC
Closing as duplicate, and moving Cc's to other bug.  Please monitor the dupe
bug from now on, and include any further updates there.

Thanks.

Comment 9 Mike A. Harris 2003-01-15 07:50:38 UTC

*** This bug has been marked as a duplicate of 79678 ***

Comment 10 Red Hat Bugzilla 2006-02-21 18:50:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.