Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80688 - RFE: Logitech Cordless MouseMan Wheel (serial) missing
Summary: RFE: Logitech Cordless MouseMan Wheel (serial) missing
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-mouse
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-29 22:17 UTC by Dr. Tilmann Bubeck
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-12 21:56:35 UTC


Attachments (Terms of Use)

Description Dr. Tilmann Bubeck 2002-12-29 22:17:46 UTC
Description of problem: 
Either redhat-config-mouse nor anaconda (during installation) offer this mouse: 
  Logitech Cordless MouseMan Wheel (serial) 
Could you please add it to the list of mice? It is completly compatible to "Microsoft 
IntelliMouse (serial)". Everything works, the mouse itself and the wheel. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. 
2. 
3. 
     
Actual results: 
 
 
Expected results: 
 
 
Additional info:

Comment 1 Brent Fox 2003-01-14 05:40:04 UTC
I need to see if the mouse can be probed.  Try this:

1) Exit X Windows and log into a console.  
2) As root, run 'python' and then run the following commands:
3) 'import kudzu'
4) 'list = kudzu.probe(kudzu.CLASS_MOUSE, kudzu.BUS_UNSPEC, kudzu.PROBE_ALL)'
5) 'print list'

Can you attach the output of that last statement to this report?

Comment 2 Dr. Tilmann Bubeck 2003-01-14 21:30:52 UTC
[root@chaos ~]# python
Python 2.2.1 (#1, Aug 30 2002, 12:15:30) 
[GCC 3.2 20020822 (Red Hat Linux Rawhide 3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> list = kudzu.probe(kudzu.CLASS_MOUSE, kudzu.BUS_UNSPEC, kudzu.PROBE_ALL)
>>> print list
[Desc:           LGI|8033
Driver:         generic
Device:         ttyS0
]
>>> 
[root@chaos ~]# 


Comment 3 Brent Fox 2003-02-11 23:51:47 UTC
Hmm, that's what I was afraid of.  The mouse can be probed but it doesn't return
anything really useful for the "Desc:" field.  I could add an option for
'Logitech Cordless MouseMan Wheel (serial)', but there's no way for me to match
up 'LGI|8033' with 'Logitech Cordless MouseMan Wheel (serial)'.

What I was hoping was that it would return something useful like it does with
USB mice.  For example, on my machine:

>>> import kudzu
>>> l = kudzu.probe(kudzu.CLASS_MOUSE, kudzu.BUS_UNSPEC, kudzu.PROBE_ALL)
>>> l
[Desc:           Logitech Inc. Cordless Mouse Receiver
Driver:         mousedev
Device:         input/mice
, Desc:           Logitech Inc. iFeel Mouse
Driver:         mousedev
Device:         input/mice
]
>>>

I'm going to mark this as 'wontfix'.  Also, my guess is that the number of
people using Logitech Cordless MouseMan Wheel with the serial port is probably
pretty small.  Most people are using PS/2 or USB these days.  In general, USB
devices are much better at reporting information about themselves to the
operating system, so our hardware detection capability will improve over time as
more people move to USB devices.

Comment 4 Dr. Tilmann Bubeck 2003-02-12 06:08:12 UTC
Could you still please add the mouse to the list, so that a common user is able 
to select its mouse? Although you are not able to autodetect it, it is still 
very usefull if one finds its own mouse in the list to manually select it 
instead of trying various different mouse types without any knowledge.

This should not do much harm if you offer one more mouse, doesn't it?

Thanks!
  Till

Comment 5 Brent Fox 2003-02-12 15:38:15 UTC
I'll see what I can do.

Comment 6 Brent Fox 2003-02-12 21:56:35 UTC
I've been told that we are past string freeze, so I can't add mice to this list
because it might not get translated in time.  I will defer this bug and revisit
it after we release the version that we're currently working on.


Note You need to log in before you can comment on or make changes to this bug.