Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80676 - Install Phoebe using FTP to Phoebe FTP server crashed
Summary: Install Phoebe using FTP to Phoebe FTP server crashed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
: 80737 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-29 17:57 UTC by Peter van Egdom
Modified: 2006-03-11 03:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-18 20:07:14 UTC


Attachments (Terms of Use)
Anaconda crashdump of failed ftp installation of Phoebe to Phoebe ftp server (deleted)
2002-12-29 17:58 UTC, Peter van Egdom
no flags Details

Description Peter van Egdom 2002-12-29 17:57:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:

I tried installing Red Hat Linux release 8.0.92 (Phoebe) on my 32 MB Pentium/100
system (the same system on which the NFS installation failed (Bugzilla bug id #
80644). 

It looked rather hopeful at first, I had a tail -f on "/var/log/vsftp.log" on
the server containing the RPM packages and saw the following line appear : 

Sun Dec 29 18:01:39 2002 2 10.0.0.1 9293824
/var/exports/8.0.92/RedHat/base/netstg2.img b _ o r peterve ftp 0 * c

After a while (after some questions regarding partioning, etc) Anaconda on the
P/100 resumed installation but crashed later on just on the moment it seemed to
begin actual installation. 

It offered to make a crash dump to floppy, which I did. I'll attach this
crashdump to this bugzilla.

Note that I - just to be sure - ftp'ed from another machine to the server
containing the RPM's using the same login/password and successfully retreived
all files in the directories "/var/exports/8.0.92/RedHat/RPMS/" and
"/var/exports/8.0.92/RedHat/base/"

So the FTP server on Phoebe works as advertised, so the actual problem in this
case is probably in Anaconda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (reproduced twice, 1st in Dutch install language, 2nd in English).
2. Put RH Phoebe CD's content on harddisk 
3. Install from another machine using FTP, use non-anonymous login, point to
location
4. Answer couple of questions about partitioning, etc.


Actual Results:  "Exception error occured" --> crashdump on floppy.

Expected Results:  FTP installation should've started.

Additional info:

vsftpd-1.1.3-3
anaconda-help-8.0.92-0.200212162051
busybox-anaconda-0.60.2-7
anaconda-runtime-8.0.92-8
anaconda-8.0.92-8
anaconda-images-8.0.92-1

standard packages of Red Hat Linux release 8.0.92 (Phoebe)

Comment 1 Peter van Egdom 2002-12-29 17:58:37 UTC
Created attachment 88979 [details]
Anaconda crashdump of failed ftp installation of Phoebe to Phoebe ftp server

Comment 2 Bill Nottingham 2003-01-01 06:17:23 UTC
*** Bug 80737 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2003-01-02 22:04:34 UTC
Fixed in python-2.2.2-8

Comment 4 Pete Zaitcev 2003-01-03 23:13:20 UTC
Is there a workaround?
Alternatively, where can I get new base/* with fixed python?


Comment 5 Mike McLean 2003-01-07 19:12:19 UTC
fix verified in -re0106.0

the workaround is to use anonymous ftp

Comment 6 Michael Fulbright 2003-02-04 19:12:23 UTC
*** Bug 83438 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.