Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80662 - kudzu claims ps2 mouse is removed when it is not
Summary: kudzu claims ps2 mouse is removed when it is not
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-29 16:40 UTC by David Balažic
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 03:32:09 UTC


Attachments (Terms of Use)

Description David Balažic 2002-12-29 16:40:01 UTC
Description of problem:

If I set SAFE=yes in /etc/sysconfig/kudzu,
then kudzu on next boot claims that my PS/2 mouse
was removed and offers to unconfigure it.
This is on RH8.0 ( Psyche ) with kudzu-0.99.69-1.
I upgraded to kudzu-0.99.83-1 and it behaves the same.


Version-Release number of selected component (if applicable):

kudzu-0.99.69-1
kudzu-0.99.83-1

How reproducible:

always

Steps to Reproduce:
1. configure a RH8.0 system with a PS/2 mouse
2. edit /etc/sysconfig/kudzu to say SAFE=yes 
3. reboot
    
Actual results:

during bootup kudzu claims that the mouse was removed

Expected results:

normal bootup, without kudzu messages

Additional info:

Comment 1 Bill Nottingham 2002-12-30 06:24:11 UTC
safe probe disables the PS/2 probe.

Comment 2 David Balažic 2002-12-30 09:02:04 UTC
If it is disabled, why is it done anyway ?
It "detects" that the mouse is removed and changes the system configuration 
accordingly. Why, if its disabled ?

Recommended fix :

 - detect changes
 - IF safemode && ps2_mouse_changed THEN
     IGNORE THAT ( because we don't know if it did really change )
 - ELSE
   do as usual
 - ENDIF


Comment 3 Bill Nottingham 2003-02-20 03:32:09 UTC
Fixed in kudzu-0.99.97-1.


Note You need to log in before you can comment on or make changes to this bug.