Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80654 - control-center settings daemon doesn't set root window background when nautilus isn't running
Summary: control-center settings daemon doesn't set root window background when nautil...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact:
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-29 15:55 UTC by Hans de Goede
Modified: 2008-05-21 11:07 UTC (History)
2 users (show)

Fixed In Version: 2.22.1-1.2008.03.26.8.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 11:07:27 UTC


Attachments (Terms of Use)

Description Hans de Goede 2002-12-29 15:55:52 UTC
Description of problem:
Background doesn't get set when logging in from gdm

Version-Release number of selected component (if applicable):
gnome-session-2.1.2-2

How reproducible:
Select no background picture, solid black background from controlpanel,
logout, saving settings, login again. gdm background is still there.

Steps to Reproduce:
1. Select no background picture, solid black background from controlpanel.
2. logout, saving settings
3. login again.
4. gdm background is still there.

Actual results:
gdm background is still there

Expected results:
black background

Comment 1 Havoc Pennington 2003-01-02 21:53:53 UTC
after logging in again, does the control panel still show the 
settings you set up?

Comment 2 Hans de Goede 2003-01-03 10:34:19 UTC
Yes, the controlpanel still shows the same settings, and changing them followed
by changing them back works (I get a black background then) but after a new
login my background doesn't get set.


Comment 3 Jonathan Blandford 2003-01-15 19:56:11 UTC
does gnome-settings-daemon run?  Did you get that out of your session somehow?

Comment 4 Hans de Goede 2003-01-15 20:32:56 UTC
Yes, gnome-settings-daemon is running, and changing the background works fine,
the problem is it just doesn't get set initialy.



Comment 5 Jonathan Blandford 2003-01-24 22:44:56 UTC
But is it running when you first log in?  Running the capplet will start the daemon.

Comment 6 Hans de Goede 2003-01-24 23:05:34 UTC
Yes it is running when I first login, before running any capplets.


Comment 7 Jonathan Blandford 2003-02-13 21:28:11 UTC
Are you running nautilus?  Do you have nautilus draw your background?

Comment 8 Hans de Goede 2003-02-13 21:32:00 UTC
Nope, I don't use nautilus


Comment 9 Hans de Goede 2003-07-24 12:49:17 UTC
Still there in severn

Comment 10 Hans de Goede 2004-07-21 14:58:47 UTC
Well,

This bug is still here with FC3 test1, although I do notice that
gnome-settings-deamon now seems to be gone from my
session-preferences, but it still is there in ps aux.

Running nautilus fixes this BTW, so people who haven't hacked nautilus
out of their config probably won't be affected.




Comment 11 Ray Strode [halfline] 2005-09-09 18:08:57 UTC
Hi Hans,

Do you still see this with FC4 and/or rawhide?

Comment 12 Hans de Goede 2005-09-09 18:35:10 UTC
I'm running a rawhide which is about a week old and still get this. After
removing "xsetroot -solid black" from desktop->preferences->more
preferences->sessions, startup programs I once again get the blue background
from gdm.

Even though the desktop background preferences are set to no wallpaper, solid black.

To reproduce goto:
desktop->preferences->more preferences->sessions, current session tab and remove
nautiles. Set you desktop background to no wallpaper solid black. logout (save
settings) log in, reproduced.

Comment 13 Bug Zapper 2008-04-03 15:26:10 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 14 Hans de Goede 2008-04-03 16:08:12 UTC
AFAIK nautilus is still responsible for setting your root window background,
rather then that gnome-settings-daemon does it, considering that backgroun
manages the icons on the root window too, this isn't that strange.

So yes, removing nautilus from your session will most likely still cause your
background to not get set. But since nautilus now is needed for things like usb
stick automount to work properly, I no longer remove it from my session and I
doubt anyone else still does, so as far as I'm concerned this bug can be closed.


Comment 15 Ray Strode [halfline] 2008-04-03 17:44:09 UTC
well gnome-settings-daemon is *supposed* to draw the background if nautilus
isn't running.

Comment 16 Matthias Clasen 2008-05-05 05:23:22 UTC
* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-1.2008.03.26.8
- Fix background drawing without nautilus



Comment 17 Fedora Update System 2008-05-05 05:34:35 UTC
gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 has been submitted as an update for Fedora 9

Comment 18 Fedora Update System 2008-05-13 14:32:18 UTC
gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3734

Comment 19 Bug Zapper 2008-05-14 01:55:09 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 20 Fedora Update System 2008-05-21 11:07:17 UTC
gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.