Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80633 - Python/GTK/bonobo install paths altered from 8.0 to phoebe
Summary: Python/GTK/bonobo install paths altered from 8.0 to phoebe
Keywords:
Status: CLOSED DUPLICATE of bug 79652
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bonobo
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-29 05:13 UTC by Jeffrey Koch
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:45 UTC


Attachments (Terms of Use)

Description Jeffrey Koch 2002-12-29 05:13:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
(bonobo) activation.so module for python not in same place as rh 8.0, this
appears to cause difficulty with hwbrowser; may be serious problem for other
python/gtk dependent packages (up2date?), since it appears the parent path has
deviated.

rh8.0:

/usr/lib/python2.2/site-packages/bonobo

phoebe:

/usr/lib/python2.2/site-packages/gtk-2.0/bonobo

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login to RH 8.0
2. cd /usr/lib/python2.2; find . -name "activation*" -print
3. Login to RH Phoebe
4. cd /usr/lib/python2.2; find . -name "activation*" -print

    

Actual Results:  

RH 8.0 has:

./site-packages/bonobo/activationmodule.so

Phoebe has:

./site-packages/gtk-2.0/bonobo/activation.so
./site-packages/gtk-2.0/bonobo/activationmodule.so


Expected Results:  Expect phoebe's install to resemble RH 8.0 for python and
associated modules.  Or, at least, that you can call the included modules for
python in phoebe without having python dependent apps blow up.

Additional info:

Force installed gnome-python2-bonobo-1.99.11-8.i386.rpm for RH 8.0 into Phoebe.
 Not pretty, but fixes python/bonobo problems in Phoebe.  (hwbrowser runs
nicely, help text for bonobo module inside python interpreter now very
informative, etc., etc.)

Just in case: Phoebe installed as upgrade from RH 8.0.

Retrieved this rpm from:

http://speakeasy.rpmfind.net/linux/RPM/gnomehide/8.0/RPMS/gnome-python2-bonobo-1.99.11-8.i386.html

Comment 1 Jeffrey Koch 2002-12-29 05:34:51 UTC
So sorry! Don't install that rpm from 8.0 on your phoebe!  The quick fix worked 
while I was logged in, but on logging out, it caused more problems, including 
GUI login hang.  (Apparently the GUI calls bonobo on login?) Removed the 8.0 
rpm and put back the others from phoebe.

Comment 2 Bill Nottingham 2003-01-01 05:52:23 UTC

*** This bug has been marked as a duplicate of 79652 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.